Project

General

Profile

Actions

Bug #14441

closed

pylint should depend on typing_extensions and astroid

Added by Rich Lowe 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

; pylint man-fixer.py
Traceback (most recent call last):
...
ModuleNotFoundError: No module named 'typing_extensions'
Actions #1

Updated by Rich Lowe 4 months ago

  • Subject changed from pylint should depend on typing_extensions to pylint should depend on typing_extensions and astroid

astroid isn't installed either

pkg_resources.DistributionNotFound: The 'astroid<2.7,>=2.6.2' distribution was not found and is required by pylint

Actions #2

Updated by Gary Mills 4 months ago

That's peculiar. The dependencies are there:

$ pkg contents -m developer/python/pylint-39 | grep ^depend
depend fmri=developer/python/pylint@2.9.3,5.11-2020.0.1.0 type=require
depend fmri=library/python/astroid-39 type=require
depend fmri=library/python/isort-39 type=require
depend fmri=library/python/mccabe-39 type=require
depend fmri=library/python/toml-39 type=require
depend fmri=pkg:/runtime/python-39@3.9.6-2020.0.1.0 type=require
Actions #3

Updated by Rich Lowe 4 months ago

it looks like typing_extensions isn't there, and astroid is maybe the wrong version?

Actions #4

Updated by Andreas Wacknitz 3 months ago

Can you check pylint again? I have updated it and its dependencies.

Actions #5

Updated by Rich Lowe 3 months ago

pkg_resources.DistributionNotFound: The 'platformdirs>=2.2.0' distribution was not found and is required by pylint

probably best to keep updating bits until you can run 'pylint'.
(I get a different error trying to pylint pkg, I'm not sure if it's a different problem or not)

Actions #6

Updated by Andreas Wacknitz about 2 months ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF