Project

General

Profile

Actions

Bug #14445

closed

ruby 3.0 or 3.1 with --enable-dtrace requires debugflags="-g1"

Added by David Stes about 2 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Hard
Tags:

Description

Ruby 3.0 and 3.1 compile fine on OpenIndiana with gcc 7.5 or gcc 10.

However when configuring with --enable-dtrace the default
debugflags of the ruby configure script is set to "debugflags=-ggdb3"

It appears that this causes the Illumos link editor "ld" to core dump / crash with SIGSEGV in the build process.

Workaround is to configure ruby 3.0 or 3.1 with debugflags="-g1"

./configure --with-gcc --enable-dtrace debugflags="-g1"

I reported this to the Ruby developers in ruby Issue #18335 owner ngoto (Naohisa Goto).
https://bugs.ruby-lang.org/issues/18335

The reply there is "Patches are welcome to check them without breaking things on other platforms (including Oracle Solaris 11).
I guess that the error/failure only occurs when processing large-scale complex source codes, and simple short source codes could be processed without error/failure. In such cases, I think it is very difficult to write short check codes that can be used in configure scripts, and I give up trying to do so."

I believe that the --enable-dtrace code was contributed in the past to the developers of Ruby,
the Ruby source code has a pointer to an old 2005 posting

https://marc.info/?l=opensolaris-dtrace-discuss&m=114761203110734&w=4

where older issues with ruby and dtrace support were discussed.


Related issues

Related to OpenIndiana Distribution - Bug #6766: dtrace probes in rubyResolvedOI Userland2016-03-19

Actions
Related to illumos gate - Bug #6653: dtrace modifies ELF string table causing problems for linkerClosed2016-02-14

Actions
Actions #1

Updated by David Stes about 2 years ago

  • Related to Bug #6766: dtrace probes in ruby added
Actions #2

Updated by David Stes about 2 years ago

  • Related to Bug #6653: dtrace modifies ELF string table causing problems for linker added
Actions #3

Updated by Marcel Telka about 1 month ago

  • Status changed from New to Feedback

Is ruby 3.2 (provided as runtime/ruby-32 package) affected too?

Actions #4

Updated by David Stes about 1 month ago

this issue relates to hard to reproduce issue with gcc and -ggdb3

this issue is difficult to compare because there is now gcc 13.2 and perhaps also updates to the link editor ld and the gcc -ggdb3 option

because it is hard to reproduce the issue can be closed and archived and may be of interest to similar issues with -ggdb3

Actions #5

Updated by Marcel Telka about 1 month ago

  • Status changed from Feedback to Closed

Okay. Closing.

Actions

Also available in: Atom PDF