Project

General

Profile

Actions

Bug #14487

open

Samsung 970 EVO Plus NVMe M.2 SSD stopped being detected by format in Tribblix and OmniOS CE installers (but boots other Unixes and GNU/Linux)

Added by David Chmelik 5 months ago. Updated 5 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

I've been trying to install Tribblix and OmniOS CE IllumOSes again (installed one or both once but didn't boot because I had to learn installboot.)
The first couple recent times, it worked to use format command then select drive and partition command and show partitions.
I tried to create a zpool accidentally on partition four (MBR extended) (zpool create -d -o ashift=12 home <device>) instead of five (for fourth OS) and of course it failed. After I rebooted, retried, format no longer detected the NVMe (but diskinfo, nvmeadm, perhaps other tools) did. I rebooted and used Slackware GNU/Linux to zero (with dd) partition four, zero the MBR, recreate the partition table (so I could still boot Slackware, FreeBSD & NetBSD Unixes.) It said it erased the ZFS signatures on partition four but when I rebooted, retried, the IllumOS installers' format command still no longer could detect the NVMe partitions. I also used FreeBSD and/or NetBSD to make sure all ZFS labels were erased.
I found correct information on fake cylinders, heads (for similar drive,) sectors, but format wouldn't take some of it, saying it was too large. I think I corrected it and format took it but with defaults showed a new, incorrect partition table.
I don't know if it's something with my workstation PC's BIOS (Biostar X470GTA) or Samsung's firmware, or various ZFS software, but after I incorrectly made a zpool then thought it was zeroed out, something still went wrong with how format detects it. The NVMe still boots Slackware, FreebSD, NetBSD just fine.
Unless there's an IllumOS LiveCD, unfortunately I'd only be able to debug by perhaps writing down information from screens (might take a long time) or otherwise using other Unixes & GNU/Linux.

Actions #1

Updated by David Chmelik 5 months ago

I took a photo of the error (updated/black-on-white: ) https://imgur.com/a/jVmZr1K .
You may be able to see format said drive type unknown
Then you may be able to see diskinfo listed the drive type I mentioned.
Fdisk shows all primary, extended/logical partitions (11) but prtvtoc only shows ones it calls 0, 2, 8.
Now the main problem (following Tribblix instructions) is since it's now 'unknown' to format, I can't format it to enlarge s0 because asks for CHS and won't take correct (though fake) answers.
Update: I created rpool and installed Tribblix and OmniOS CE but need to installboot for both (separate issue, not bug.) I guess format not recognizing the drive is okay for now when enough other tools do.
Update: I have no VTOC that makes sense but was told only having a VTOC is supported, but I can't get that without the format command or some other tricks that I still have to hear about... so I'd need the original problem solved, or a new SSD, before I can install.

Actions

Also available in: Atom PDF