Project

General

Profile

Actions

Bug #14509

closed

nvmeadm commit-firmware error reporting isn't working as intended

Added by Hans Rosenfeld 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
driver - device drivers
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

A while back, nvme_ioctl_firmware_commit() got the ability to return the error status (SCT and SC) from failed commands that were executed on its behalf. But there are still those many cases when the ioctl() can fail and return an error in errno without even having sent a command to the hardware, which consumers of this interface like nvmeadm(1M) can't easily detect as such.


Related issues

Related to illumos gate - Bug #14508: improve nvmeadm firmware reportingClosedHans Rosenfeld

Actions
Related to illumos gate - Bug #14507: nvmeadm shouldn't allow writing firmware to a read-only slot 1ClosedHans Rosenfeld

Actions
Actions #1

Updated by Electric Monk 6 months ago

  • Gerrit CR set to 2025
Actions #2

Updated by Hans Rosenfeld 6 months ago

  • Related to Bug #14508: improve nvmeadm firmware reporting added
Actions #3

Updated by Hans Rosenfeld 6 months ago

Testing: I've tested this extensively on Tintri systems, but not on stock illumos-gate as I don't have any firmware updates for my old NVMe drives.

Actions #4

Updated by Hans Rosenfeld 6 months ago

  • Related to Bug #14507: nvmeadm shouldn't allow writing firmware to a read-only slot 1 added
Actions #5

Updated by Electric Monk 6 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 8466ab889653be2119e4a8966b6bc4e2d5ee2fb6

commit  8466ab889653be2119e4a8966b6bc4e2d5ee2fb6
Author: Hans Rosenfeld <rosenfeld@grumpf.hope-2000.org>
Date:   2022-02-22T09:13:21.000Z

    14507 nvmeadm shouldn't allow writing firmware to a read-only slot 1
    14508 improve nvmeadm firmware reporting
    14509 nvmeadm commit-firmware error reporting isn't working as intended
    Reviewed by: Guy Morrogh <gmorrogh@tintri.com>
    Reviewed by: Yuri Pankov <ypankov@tintri.com>
    Reviewed by: Andy Giles <agiles@tintri.com>
    Reviewed by: Robert Mustacchi <rm+illumos@fingolfin.org>
    Reviewed by: Andy Fiddaman <andy@omnios.org>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF