Project

General

Profile

Actions

Bug #14531

closed

want nvme namespace management mutex

Added by Hans Rosenfeld 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
driver - device drivers
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The nvme driver really should have a namespace management mutex serializing any changes to namespace state. Right now this will only be used for blkdev attach and detach, but at a lite time it will also be required for supporting namespace creation and deletion.

This code was taken from Paul Winders namespace management wad, and it includes a fair bit of refactoring and cleanup of the namespace initialization and attachment.

Actions #1

Updated by Electric Monk 3 months ago

  • Gerrit CR set to 2050
Actions #2

Updated by Hans Rosenfeld about 1 month ago

Testing: Apart from this having been in Tintri's code for a few months now, I have verified that operations changing namespace state still work as expected. Further changes I'm currently still working on depend on this change, so I'm fairly confident it all works as intended.

Actions #3

Updated by Electric Monk about 1 month ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 34331de35882eb41acdf4f0d2065b5e12d083e82

commit  34331de35882eb41acdf4f0d2065b5e12d083e82
Author: Hans Rosenfeld <rosenfeld@grumpf.hope-2000.org>
Date:   2022-04-20T17:42:38.000Z

    14531 want nvme namespace management mutex
    Contributed by: Paul Winder <paul@winder.uk.net>
    Reviewed by: Andrew Giles <agiles@tintri.com>
    Reviewed by: Guy Morrogh <gmorrogh@tintri.com>
    Reviewed by: Ben Jameson <bjameson@tintri.com>
    Reviewed by: Robert Mustacchi <rm+illumos@fingolfin.org>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF