Project

General

Profile

Bug #1459

oi-build meta-packages/history/SUNWfppd has incorrect dependency

Added by Alasdair Lumsden over 8 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
OI-Userland
Target version:
-
Start date:
2011-09-04
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

This historical package has a factual inaccuracy - the version number should be:

-depend fmri= type=require
+depend fmri= type=require

This was found when attempting to build the replacement foomatic-ppds, which wouldn't install.

The SUNWfppd package in oi_151 from /dev-il contains:

alasdair ~ (ninja.rar): uname -a
SunOS ninja.rar.nu 5.11 oi_151a i86pc i386 i86pc Solaris
alasdair ~ (ninja.rar): pkg contents -mr pkg:,5.11-0.133
set name=pkg.fmri value=pkg:,5.11-0.133:20100914T025302Z
set name=org.opensolaris.consolidation value=sfw
set name=pkg.renamed value=true
set name=variant.arch value=i386
set name=variant.opensolaris.zone value=global value=nonglobal
depend fmri= type=require

Repairing the version dependency fixes installing foomatic-ppds.

History

#1

Updated by Alasdair Lumsden over 8 years ago

  • Status changed from New to Resolved
  • % Done changed from 50 to 100

Also available in: Atom PDF