Project

General

Profile

Bug #1484

upgrading to oi_151a blocking on hard drive

Added by Jonathan Adams almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2011-09-09
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

I am currently running on kernel: illumos d89753efabc8.

I have recently tried upgrading my system to the latest in the oi-dev
OpenIndiana repository ... and was getting large numbers of time-outs
when rebooting into the newer kernels, and gave up for a little while
to see if there was still work happening in changing the kernel.

a few days ago, after updating to the latest kernel I rebooted the
machine and left for the evening to see if it would boot after a very
long time.

This morning I was pleasantly surprised to find a log on screen, and
was able to log on to the computer, but it appeared to be sluggish.

Knowing that it did boot I decided to boot the latest kernel with the
verbose option ... and it all booted, slowly, but with no noticeable
differences to a normal boot (with the exception of "network/location
Method or service timed out" after about 5 minutes.

after booting it appeared to be sluggish again, so i ran an "iostat
-zxc 5" and noticed that my hard disk was running with 100% blocking
most of the time, with very low disk usage.

I started some applications (gedit, firefox, thunderbird ...) firefox
and thunderbird were essentially unusable, gedit was just about able
to open and save files.

it's a Dell Latitude E5500 laptop with a 2.5" internal SATA drive.

highlights from the BIOS:

SATA is in AHCI mode
External eSATA ports are enabled (although I can't see any so I could
probably turn this off ... :)
Execute Disable bit is enabled.
Multicore Support + Intel Speedstep are enabled
Intel Virtualization + VT for Direct I/O are also enabled.

this system works fine for Illumos d89753efabc8 kernel, but none of
the ones released in the last 3 weeks or so to the dev-il repository.

I would really like to be able to upgrade and look at the kvm code,
and am happy to give any information/logs that are needed.

attached is my "scanpci -v" output


Files

scanpci.txt (11.1 KB) scanpci.txt Jonathan Adams, 2011-09-09 09:53 AM
f342d0516376.dmesg (24.1 KB) f342d0516376.dmesg "dmesg" command output Jonathan Adams, 2011-09-29 12:39 PM
f342d0516376.fmdump (17 KB) f342d0516376.fmdump "fmdump -v" command output Jonathan Adams, 2011-09-29 12:39 PM
f342d0516376.last-head (678 Bytes) f342d0516376.last-head "last" command output Jonathan Adams, 2011-09-29 12:39 PM

History

#1

Updated by Jonathan Adams almost 8 years ago

Tried updating again yesterday and it still fails.

last known working kernel:
root@jadlaptop:~# pkg info consolidation/osnet/osnet-incorporation
Name: consolidation/osnet/osnet-incorporation
Summary: OS/Net consolidation incorporation
Description: This incorporation constrains packages from the OS/Net
consolidation.
State: Installed
Publisher: openindiana.org
Version: 0.5.11
Build Release: 5.11
Branch: 0.151
Packaging Date: Mon May 23 15:28:20 2011
Size: 0.00 B
FMRI: pkg:,5.11-0.151:20110523T152820Z

#2

Updated by Igor Kozhukhov almost 8 years ago

I have updated OI to 151a on my bare metal: Core2Quad 9300/8GB RAM/2x2TB(mirror) SATA hdd
Works well about 2 weeks

#3

Updated by Jonathan Adams almost 8 years ago

I'm sure you do, but it doesn't make my machine not work with an update to the kernel.

#4

Updated by Rich Lowe almost 8 years ago

Jonathan Adams wrote:

FMRI: pkg:,5.11-0.151:20110523T152820Z

That's (as evidenced by the timestamp) not particularly new. What's your publisher configuration (pkg publisher)? Or is that the build which works?

Current /dev bits from OI should have a branch version of 0.151.1

I don't know of anything that'd specifically damage I/O, but there has been an issue which would greatly pessimize DMA performance, since fixed.

#5

Updated by Jonathan Adams almost 8 years ago

jadams@jadlaptop:~$ pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev-il/
opensolaris.org (non-sticky, disabled) origin online http://pkg.opensolaris.org/dev/
localhost (non-sticky, disabled) origin online http://localhost:10000/
homeunix (non-sticky, disabled) origin online http://ips.homeunix.com:10906/
kvm-test origin online http://pkg.openindiana.org/kvm-test/
sfe-encumbered origin online http://pkg.openindiana.org/sfe-encumbered/
sfe origin online http://pkg.openindiana.org/sfe/

I will try to update again today, and will reboot before end of play to see if it works.

#6

Updated by Jonathan Adams almost 8 years ago

root@jadlaptop:~# pkg refresh ; pkg update
Packages to update: 925
Create boot environment: Yes
DOWNLOAD PKGS FILES XFER (MB)
Completed 925/925 17367/17367 516.9/516.9

PHASE ACTIONS
Removal Phase 7068/7068
Install Phase 8155/8155
Update Phase 25366/25366

PHASE ITEMS
Package State Update Phase 1850/1850
Package Cache Update Phase 925/925
Image State Update Phase 2/2

PHASE ITEMS
Reading Existing Index 8/8
Indexing Packages 925/925
Indexing Packages 925/925
Optimizing Index...

PHASE ITEMS
Indexing Packages 962/962

A clone of illumos-4 exists and has been updated and activated.
On the next boot the Boot Environment illumos-5 will be mounted on '/'.
Reboot when ready to switch to this updated BE.

---------------------------------------------------------------------------
NOTE: Please review release notes posted at:

http://wiki.openindiana.org/oi/oi_151a+Release+Notes
---------------------------------------------------------------------------

I will restart at lunch time and see if it's up within the hour.

#7

Updated by Jonathan Adams almost 8 years ago

New kernel f342d051b376

Took about 50 minutes to boot to the login screen ...

(10 just to get to the "Hostname: jadlaptop" line)

Hopefully the attached files will help in some way.

Old errors (before today) in fmdump generally refer to an external USB drive called "jadpool", which doesn't play nice on a reboot

#8

Updated by Jonathan Adams almost 8 years ago

Are there any other tests that you would like me to try? this is a blocker for me, even if it isn't affecting many other people yet.

#9

Updated by Jonathan Adams almost 8 years ago

just for completeness sake, I tried tried upgrading to kernel f342d051b376 ... still having serious blocking issues.

#10

Updated by Jonathan Adams almost 8 years ago

Jonathan Adams wrote:

just for completeness sake, I tried tried upgrading to kernel f342d051b376 ... still having serious blocking issues.

I mean, I tried upgrading again yesterday ...

#11

Updated by Jonathan Adams over 7 years ago

Upgraded to latest kernel (as of Friday 16th) from dev-il and the blocking issues seem to have "disappeared".

thanks everyone.

#12

Updated by Milan Jurik over 7 years ago

  • Status changed from New to Closed

It looks like problem was resolved in the latest OI bits.

Also available in: Atom PDF