Project

General

Profile

Actions

Bug #14847

closed

illumos should default to python 3.9

Added by Rich Lowe 3 months ago. Updated 23 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
tools - gate/build tools
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:
External Bug:

Description

We should flip the python3/3b versions to match the most common reality

Actions #1

Updated by Electric Monk about 1 month ago

  • Gerrit CR set to 2333
Actions #2

Updated by Rich Lowe about 1 month ago

testing:

- full build letting the python versions default
- checked that the important #! lines in our bits were 3.9
- installed that full build and used pkg/beadm
- built again and used pkg/beadm to upgrade to that build.

Actions #3

Updated by Electric Monk 23 days ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 36afce5d646a7506053384370adfe4c6ac1a6047

commit  36afce5d646a7506053384370adfe4c6ac1a6047
Author: Richard Lowe <richlowe@richlowe.net>
Date:   2022-09-14T20:08:05.000Z

    14847 illumos should default to python 3.9
    Reviewed by: Marcel Telka <marcel@telka.sk>
    Approved by: Dan McDonald <danmcd@mnx.io>

Actions

Also available in: Atom PDF