Project

General

Profile

Actions

Bug #15012

closed

nightly should fail if tools build failed

Added by Yuri Pankov 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
tools - gate/build tools
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:
External Bug:

Description

If tools build failed for any reason (for me it was a simple mismerge), nightly should not continue and fail immediately as the build is doomed already, and errors reported afterwards usually don't have anything to do with real issues and are caused by missing native tools.

Change tested by deliberately making one of the tools fail to build and checking that nightly did NOT continue building the rest of the tree.

Actions #1

Updated by Electric Monk 3 months ago

  • Gerrit CR set to 2395
Actions #2

Updated by Yuri Pankov 2 months ago

  • Description updated (diff)
  • Status changed from In Progress to Pending RTI
  • % Done changed from 90 to 100
Actions #3

Updated by Electric Monk about 2 months ago

  • Status changed from Pending RTI to Closed

git commit 6faa6645c7a15dbddad859508e1f766bf1cef639

commit  6faa6645c7a15dbddad859508e1f766bf1cef639
Author: Yuri Pankov <ypankov@tintri.com>
Date:   2022-10-10T13:50:57.000Z

    15012 nightly should fail if tools build failed
    Reviewed by: Alexander Eremin <aeremin@tintri.com>
    Reviewed by: Guy Morrogh <gmorrogh@tintri.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Dan McDonald <danmcd@mnx.io>

Actions

Also available in: Atom PDF