Project

General

Profile

Feature #1514

update onbld GOOD_VERSIONS to use mercurial 1.8.4

Added by Bayard Bell about 8 years ago. Updated over 7 years ago.

Status:
New
Priority:
Low
Assignee:
Category:
tools - gate/build tools
Start date:
2011-09-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:

Description

Mercurial 1.8.4 uses python 2.6 as its interpreter. In order to transition the onbld scripts off of python2.4, GOOD_VERSIONS needs to be updated to support that version of hg.

History

#1

Updated by Rich Lowe about 8 years ago

This should actually be primarily a matter of updating the mercurial people use to use Python2.6 (or at least to deliver python2.6 bits, and have /usr/bin/hg use it). I think I dealt with everything else while making it work in preparation for that.

#2

Updated by Alexander Eremin about 8 years ago

May be make sence to use already 2.7? It seems Oracle already doing this...

#3

Updated by Rich Lowe about 8 years ago

Oracle are shipping 2.7, they're not using it by default.

It'd make sense for us to use, but someone would have to do any associated work, which is already done for 2.6

#4

Updated by Bayard Bell about 8 years ago

Rich Lowe wrote:

This should actually be primarily a matter of updating the mercurial people use to use Python2.6 (or at least to deliver python2.6 bits, and have /usr/bin/hg use it). I think I dealt with everything else while making it work in preparation for that.

I may be misunderstanding what you mean by "updating the mercurial people to use Python2.6". hg and friends normally invoke python with "#!/usr/bin/env python", with, at least in the recent Mercurial release shipping with OI, is altered to "#!/usr/bin/python2.6" (which is good, as pkgdepend will throw a tantrum with former interpreter spec). My thought was first to move the consumers of the onbld Mercurial glue to all use python2.6, then to update GOOD_VERSIONS in Scm/Version.py to support the Mercurial shipping with OI, which is 1.8.4.

The larger plan would be to get Illumos onto the Mercurial 1.8 releases and to remove some of the very dated Mercurial versions that are specified in GOOD_VERSIONS, such that we're in a position to leverage functionality that's matured in later versions. I'll immediately acknowledge that I haven't identified any such functionality as required so much as possibly desirable (at least for the goals that we were trying to set for OI).

If that's more squishy than you should reasonably expect after an attempt at clarification, you're not wrong.

#5

Updated by Bayard Bell about 8 years ago

Incidentally, as far as the cause of removing python-24 dependencies from Illumos goes, these scripts appear to be the last remaining bits. As best as I can make out, the case is:

1) eliminate support for two pythons where we need only one and the other is old and unsupported
2) I already gave this a quick stab, and everything seems to just work when the onbld scripts switch to 2.6, which makes me think this is a straightforward and simple change
3) this makes it a modicum easier to slim GOOD_VERSIONS down to things that are currently supported and to keep it up-to-date

Unless I'm missing something, this looks like a simple change that can be done in less time than we'll end up taking to discuss it. We don't have support for 2.7 at all, and I see no reason to make sorting that a pre-req here.

#6

Updated by Rich Lowe about 8 years ago

I had no idea that OI had updated Mercurial underneath us in that manner.
The change to GOOD_VERSIONS should be made quickly, before it really annoys people. Are you doing that in this bug? I'd suggest a separate one that could turn over faster.

#7

Updated by Bayard Bell over 7 years ago

  • Subject changed from update onbld python scripts to use python2.6 interpreter exclusively to update onbld GOOD_VERSIONS to use mercurial 1.8.4

Also available in: Atom PDF