Project

General

Profile

Bug #1523

OI151a can't access Symbios 53c875

Added by Peter Tribble about 9 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Drivers
Target version:
-
Start date:
2011-09-15
Due date:
2011-09-30
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Bite-size
Tags:
glm

Description

I have a system with several Symbios 53c875 SCSI cards. These aren't picked up by OI151a.

At least, the device driver utility says it doesn't have a driver for them.

They work fine with 2009.06, using the ncrs driver. From path_to_inst there, I see:

"/pci@0,0/pci8086,244e@1e/pci1000,1000@0" 0 "ncrs"
"/pci@0,0/pci8086,244e@1e/pci1000,1000@1" 1 "ncrs"
"/pci@0,0/pci8086,244e@1e/pci1000,1000@1,1" 2 "ncrs"

Now, ncrs has gone. Should glm be a viable replacement?

#1

Updated by Ken Mays about 9 years ago

  • Due date set to 2011-09-30
  • Category set to Drivers
  • Status changed from New to Feedback
  • Assignee set to OI illumos
  • Priority changed from Normal to Low
  • Target version set to oi_151_stable
  • Estimated time set to 1.00 h
  • Difficulty changed from Medium to Bite-size
  • Tags changed from needs-triage to glm

Peter - Yes, the glm driver is provided:
,5.11-0.151.1:20110912T031049Z
Please test and review for functionality with your system.

#2

Updated by Ken Mays about 9 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from OI illumos to Ken Mays
  • % Done changed from 0 to 100

No work needed. Closing ticket.

#3

Updated by Peter Tribble about 9 years ago

  • Status changed from Resolved to Feedback
  • % Done changed from 100 to 0

Need to reopen.

I'm aware that glm is provided. However, it doesn't actually work.

The problem is that the extra driver aliases for glm haven't been added. In my case, it's pci1000,f, so if I manually:

update_drv -a -i '"pci1000,f"' glm

then I can see my disks. Presumably this (and any other aliases that used to be supported by ncrs but are now supported by glm) need to be added to /etc/driver_aliases

#4

Updated by Ken Mays about 9 years ago

  • Assignee changed from Ken Mays to OI illumos

Peter - Thanks for your verification of this as I did note the missing pci-ids, but didn't know if it was intentional for a reason or just an oversight of the driver packaging.

I'll push this to illumos-gate to add the pci-ids to the glm driver for:
pci1000,1
pci1000,2
pci1000,3
pci1000,4
pci1000,6
pci1000,c
pci1000,f

#5

Updated by Garrett D'Amore about 9 years ago

The missing device ids are more complex than you might realize, because it turns out that under a given device id, there are different chip versions, and glm can support some, but not all of those versions.

Sadly, this just isn't as cut and dried as it should be.

Short of modifying glm to support all the legacy parts, I'm not sure what the right answer here is. I'm inclined to just leave those parts out .. there aren't that many of these legacy controllers still out there in the field.

#6

Updated by Peter Tribble about 9 years ago

I see two choices. We could simply have glm on x86 have the same list of device ids as on sparc. There's a certain level of consistency there. Or we get it to acquire everything from ncrs. I think I would much rather offer to support as many ids as possible, rather than desupport a load of hardware that actually will work.

#7

Updated by Ken Mays almost 8 years ago

  • Status changed from Feedback to Closed
  • Assignee changed from OI illumos to Ken Mays
  • Target version deleted (oi_151_stable)
  • % Done changed from 0 to 100

Closed ticket.
Resolution is to install:
1. pfexec pkg install ,5.11-0.175.1.0.0.24.2:20120919T184349Z @ pkg.oracle.com
If work allows: import to pkg.openindiana.org

Also available in: Atom PDF