Project

General

Profile

Bug #1530

perl-584 should be obsoleted rather than renamed

Added by Bayard Bell over 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Release Engineering
Target version:
Start date:
2011-09-16
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Perl

Description

OI dealt with the removal from runtime/perl-584 by maintaining a manifest for that renamed it to 510. This was intended to deal with the removal by providing a smooth transition path, but it now looks to be masking other bugs, as recently turned out to be the case with some Illumos manifests. (The Illumos issues is #1521, and those changes, now pending developer@ review, will need to be pulled into the OI illumos-gate once integrated upstream.)

OI will need to make a change to its illumos-gate used in 151, marking the 5.8.4 runtime as obsolete rather than renamed, which can be expected to break some things and reveal bugs in the process.

History

#1

Updated by Chris Jordan over 8 years ago

  • Category changed from OS/Net (Kernel and Userland) to Release Engineering
  • Assignee set to OI PKG
  • Tags set to Perl
#2

Updated by Bayard Bell about 8 years ago

  • Assignee changed from OI PKG to OI illumos
  • Priority changed from Normal to High

This allows broken packaging to go unnoticed, and having dependencies on 5.8.4 survive means that removing the placeholder package actually breaks onu. This was fixed upstream as illumos issue 1521, which has since been integrated.

#3

Updated by Jon Tibble almost 8 years ago

  • Status changed from New to Resolved

Fixed in prestable2

Also available in: Atom PDF