Project

General

Profile

Bug #1534

VirtualBox (4.1.2) suddenly core dumps after latest 151 changes

Added by Predrag Zečević about 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-09-18
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

VB was working until latest updates (well i am using /dev-il repo, but it also could be a case for normal repo), then suddenly does core dump.

$ tail -1 /var/adm/messages
Sep 18 13:06:10 solarix genunix: [ID 603404 kern.notice] NOTICE: core_log: VBoxSVC10730 core dumped: /var/cores/core.VBoxSVC.uid0.10730@1316343968

$ pkg info pkg
pkg info pkg
Name: package/pkg
Summary: Image Packaging System
Description: The Image Packaging System (IPS), or pkg(5), is the software
delivery system used on OpenSolaris systems. This package
contains the core command-line components and depot server.
Category: System/Packaging
State: Installed
Publisher: openindiana.org
Version: 0.5.11
Build Release: 5.11
Branch: 0.151.1
Packaging Date: Mon Sep 12 03:13:38 2011
Size: 5.27 MB
FMRI: pkg:,5.11-0.151.1:20110912T031338Z

$ pkg publisher -a
pkg publisher -a
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev-il/
sfe origin online http://pkg.openindiana.org/sfe/
sfe-encumbered origin online http://pkg.openindiana.org/sfe-encumbered/

I found someone else have same problem (http://ewaldertl.blogspot.com/2011/09/virtualbox-in-openindiana-suddenly.html) and i have tried to apply (very OLD opensolaris bug): http://www.virtualbox.org/ticket/1840

and it worked!

Workaround - Start shell (in this case bash) and:

export LD_NODIRECT=1
VirtualBox &

I can remember this error, but it was solved long time ago. Now, it looks like some change was lost on its way to OpenIndiana (only with recent updates - it was working like charm before)

History

#1

Updated by Predrag Zečević almost 9 years ago

Further more,
after fixing this (and minor problem with USB device access), staring any VirtualBox guest crashes my OI host.

Host freezes for almost 5 minutes and then reboots.
Nothing in any log file is written.

#2

Updated by Predrag Zečević almost 9 years ago

Well,

i did fresh installation of IO 151a (USB Desktop image, added some SFE software) and still have problem to start VirtualBox:

$ sudo pkgadd -d VirtualBox-4.1.2-SunOS-r73507.pkg -n -a autoresponse SUNWvbox
Checking for older bits...
Installing new ones...
Detected Solaris 5.11 Version 151
Loading VirtualBox kernel modules...
- Loaded: Host module
- Loaded: NetAdapter module
- Loaded: NetFilter (STREAMS) module
- Loaded: USBMonitor module
- Loaded: USB module
Configuring services...
- Loaded: Zone access service
Installing MIME types and icons...
Installing Python bindings...
- Installed: Bindings for Python 2.4
- Installed: Bindings for Python 2.6
Updating the boot archive...

Installation of <SUNWvbox> was successful.

$ sudo VBoxManage extpack install ../Oracle_VM_VirtualBox_Extension_Pack-4.1.2-73507.vbox-extpack
VBoxManage: error: Failed to create the VirtualBox object!
VBoxManage: error: Code NS_ERROR_ABORT (0x80004004) - Operation aborted (extended info not available)
VBoxManage: error: Most likely, the VirtualBox COM server is not running or failed to start.

For me, this is very important to be solved.

Regards.

#3

Updated by Predrag Zečević almost 9 years ago

  • Status changed from New to Feedback

Well, just found (http://wiki.openindiana.org/oi/Spec+Files+Extra+Repository):

---8<---
VirtualBox and GCC 4.6 libgcc_s.so.1

SFE delivers symlinks for libgcc_s.so.1 and libstdc++.so.6 into /usr/lib as the OpenIndiana project intends to transition to gcc 4.6 as its default compiler. At the present time, this is known to break VirtualBox. You can fix this by invoking the VirtualBox binary as follows:

LD_LIBRARY_PATH=/usr/sfw/lib/amd64 VirtualBox

Or the following if you are on a 32 bit system:

LD_LIBRARY_PATH=/usr/sfw/lib VirtualBox
---8<-----

Sorry for confusion. It is likely to be rejected.

#4

Updated by Alex Viskovatoff almost 9 years ago

This is a perplexing problem, especially since it does not occur on Solaris 11 Early Adaptor, which comes with gcc 4.5 and places links to its runtime libraries in /usr/lib the way SFE's gcc does. So for an unknown reason, gcc 4.6 breaks vbox but gcc 4.5 does not.

That LD_NODIRECT=1 stops vbox from crashing suggests that vbox was built using direct binding, and that that is causing the problem. A bug report should be filed on the vbox bug tracker, but I think it is best to wait until OI has it own official gcc 4.6 to do that.

#5

Updated by Predrag Zečević almost 9 years ago

I am also fine with LD_LIBRARY_PATH=/usr/sfw/lib/amd64 VBoxHeadless (or VBoxManage) usage.

Thanks and best regards.

#6

Updated by Ken Mays over 7 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Closing ticket based on user feedback

Also available in: Atom PDF