Project

General

Profile

Actions

Bug #15369

open

cannot join ad Domain member on samba 4.17.4

Added by vanni della about 1 year ago. Updated 14 days ago.

Status:
In Progress
Priority:
Normal
Assignee:
-
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
samba

Description

We have an samba server on OI installatio, after samba update is necessary rejoin the server at active-directory.
but whit latest OI upddate we cannot join procedure fails with this error.

  1. samba-tool domain join <DOMAIN> MEMBER -U administrator
    abort_handler_s: memset_s: n > smax
    Abort
Actions #1

Updated by Justin Woody about 1 year ago

Also seeing this error from Samba 4.17.3 on SmartOS 22.4.0 during client connection attempts. Log snip:

==> log.rpcd_classic <==
[2023/02/07 02:07:56,  0] ../../source3/rpc_server/rpc_worker.c:1105(rpc_worker_main)
  rpcd_classic version 4.17.3 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2022
abort_handler_s: memset_s: n > smax

Ubuntu client:

smbclient -L //[host] -U [user]
Enter WORKGROUP\[user]'s password: 

    Sharename       Type      Comment
    ---------       ----      -------
cli_rpc_pipe_open_noauth: rpc_pipe_bind for pipe srvsvc failed with error NT_STATUS_CONNECTION_DISCONNECTED
SMB1 disabled -- no workgroup available

Actions #2

Updated by Toomas Soome about 1 year ago

  • Project changed from illumos gate to OpenIndiana Distribution

Moved to OI

Actions #3

Updated by Marcel Telka about 2 months ago

  • Status changed from New to Feedback

Is this issue reproducible with recent samba version available (4.19.4 as of today)?

Actions #4

Updated by Marcel Telka about 2 months ago

  • Category set to OI-Userland
Actions #5

Updated by Marcel Telka about 2 months ago

  • Assignee set to vanni della
Actions #6

Updated by Marcel Telka about 1 month ago

  • Target version set to Hipster
Actions #7

Updated by Marcel Telka about 1 month ago

  • Tags set to samba
Actions #8

Updated by Mark Guleno 14 days ago

Yes, the error still happens with Samba 4.19.4. I just ran into it on SmartOS base-64-trunk 20240116:

# samba -i -M standard
samba version 4.19.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2023
abort_handler_s: memset_s: n > smax
standard_child_pipe_handler: Child 26031 (kdc) terminated with signal 6

I was able to trigger the error by running the following on the DC:

# net ads status
Password for [Administrator@MY.EXAMPLE.COM]:
kerberos_kinit_password MY@MY.EXAMPLE.COM failed: Cannot contact any KDC for requested realm

Actions #9

Updated by Marcel Telka 14 days ago

  • Status changed from Feedback to In Progress
  • Assignee deleted (vanni della)

Mark Guleno wrote in #note-8:

Yes, the error still happens with Samba 4.19.4. I just ran into it on SmartOS base-64-trunk 20240116:

If it is reproducible on both OpenIndiana and SmartOS then it looks like an upstream samba bug. I recommend to report it directly to samba upstream (and paste a link to the bug report here).

Actions

Also available in: Atom PDF