Project

General

Profile

Bug #1656

add dependency 'sunwcs' to package 'system/data/terminfo'

Added by Igor Kozhukhov almost 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2011-10-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

as can I see some terminfo files have been moved from 'sunwcs' to 'system/data/terminfo'
for normal upgrade packages we have to update 'sunwcs' before 'system/data/terminfo'.
need add dependency 'sunwcs' to 'system/data/terminfo'

History

#1

Updated by Yuri Pankov almost 8 years ago

SUNWcs already depends on system-data-terminfo, why do you want it to depend backwards?

#2

Updated by Igor Kozhukhov almost 8 years ago

need revert dependency - need update dependency to 'system/data/terminfo' from "SUNWcs".
I'm working on converting IPS packages to DEB and I have problems with UPGRADE procedure, because some terminfo file have been moved to 'system/data/terminfo' and this trying install before SUNWcs.

#3

Updated by Igor Kozhukhov almost 8 years ago

and need remove from SUNWcs:
depend fmri=runtime/perl-584 type=require
it is old Perl.

#4

Updated by Yuri Pankov almost 8 years ago

This sounds more like ips -> deb conversion task than something that should be "fixed" in illumos pkg manifests.

#5

Updated by Yuri Pankov almost 8 years ago

However, I would agree with just adding system-data-terminfo to some sort of 'consolidation' (if it's not there yet) instead of having it as dependency for SUNWcs and print-lp (most other CLI tools probably do need it too).

#6

Updated by Igor Kozhukhov almost 8 years ago

it is problem not in DPKG.
I want to show that IPS is working incorrect.
IPS package manager can provide the same files in different packages - it is mistake in another package managers - every file should be providing at one package.
As I know SUNWcs package provide structure and main files.
I think need remove dependency 'terminfo' from SUNWcs and add dependency 'SUNWcs' to terminfo.
we can add 'terminfo' dependency to consolidation-osnet.
I have found this mistake by converting IPS->DEB.

#7

Updated by Igor Kozhukhov almost 8 years ago

IPS package manager have flag '--non-sticky' if you want overtire changes from another package. But will be better to have structure of packages with original files - without duplicates. For safely system need identify right dependency - what packages need install before another.
I think for this BUG will be better to have installed SUNWcs before terminfo.

#8

Updated by Rich Lowe almost 8 years ago

  • osnet-incorporation should not contain dependencies of types other than 'incorporate'
  • The dependencies of terminfo and SUNWcs look fine to me as they are
  • The fact IPS used to let you deliver the same file in two packages is, yes, a bug, but it doesn't seem related to what you're describing (and what you're describing won't fix it).
#9

Updated by Yuri Pankov almost 7 years ago

Should this probably be closed as not a bug?

#10

Updated by Igor Kozhukhov almost 7 years ago

  • Status changed from New to Closed

was discussed - it's not a bug

Also available in: Atom PDF