Project

General

Profile

Actions

Bug #1689

closed

hg case-folding collision on case-insensitive filesystems

Added by Dan Kruchinin almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
2011-10-26
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

I'm not sure it's a proper place to report the bug, but this section seemed to me a bit more suitable than others.

BUG:
It's impossible to check out illumos-gate repository on case-insensitive filesystems such as vfat, ntfs, hfs+
hg outputs the following:

% hg clone ssh://anonhg@hg.illumos.org/illumos-gate                                                                                                     
The authenticity of host 'hg.illumos.org (72.2.120.74)' can't be established.
RSA key fingerprint is 8d:02:b6:5a:9c:62:6e:2e:39:98:4a:6c:09:14:63:4f.
Are you sure you want to continue connecting (yes/no)? yes
remote: Warning: Permanently added 'hg.illumos.org,72.2.120.74' (RSA) to the list of known hosts.
destination directory: illumos-gate
requesting all changes
adding changesets
adding manifests
adding file changes
added 13495 changesets with 162425 changes to 64538 files
updating to branch default
abort: case-folding collision between usr/src/cmd/lp/filter/postscript/font/devpost/Hb and usr/src/cmd/lp/filter/postscript/font/devpost/HB

Related issues

Is duplicate of illumos gate - Bug #633: case-folding collision in illumos-gateResolvedGarrett D'Amore2011-01-15

Actions
Actions #1

Updated by Rich Lowe almost 10 years ago

  • Status changed from New to Closed

Duplicate of #633

Actions

Also available in: Atom PDF