Project

General

Profile

Bug #1756

iwp missing some Centrino 6205 IDs

Added by Albert Lee almost 8 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
driver - device drivers
Start date:
2011-11-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
wifi

Description

The IDs are also hardcoded in the driver for antenna configuration info. See http://pci-ids.ucw.cz/read/PC/8086


Files

iwp (537 KB) iwp iwp with PCI ID checks removed, default to two antennas for 62xx Albert Lee, 2011-11-10 03:29 PM
blah.diff (1.01 KB) blah.diff Albert Lee, 2013-09-06 04:42 AM
blah.diff (1.01 KB) blah.diff Albert Lee, 2013-09-06 04:58 AM

Related issues

Is duplicate of illumos gate - Bug #1237: port Intel WifiLink 4965/100/1000/2000/5000/6000 driverClosed2011-07-21

Actions

History

#1

Updated by Albert Lee almost 8 years ago

Namely: 0x82, 0x85 (6205), 0x86, 0x88 (6050), 0x87, 0x89 (6250), 0x8f (unidentified 6000 series), 0x90, 0x91 (6230).

(Also unclear why the iwp aliases are padded with 0s, and whether this is legal for matching compatible strings).

#2

Updated by Albert Lee almost 8 years ago

Attached is a potential workaround for Centrino 62xx devices which are currently unrecognised. Run:

cp  iwp /kernel/drv/amd64/iwp
update_drv -a -i '"pciex8086,<your PCI ID without leading 0s>"' iwp

#3

Updated by Dan McDonald about 7 years ago

Why isn't this fix in illumos-gate? (Or at the very least OI's child of it?)

Need review cycles? More tests? More time?

#4

Updated by Ryo Murakawa almost 7 years ago

I installed OI151a7 on my ASUS U36s. I replaced wifi from N1000 to N6230. And I followed the above steps. My N6230 was detected. But this card couldn't detect Wifi station.

#5

Updated by Albert Lee almost 7 years ago

  • Difficulty changed from Bite-size to Medium

It's possible this change is not sufficient for all 62xx devices. They seemed to be compatible based on using the FreeBSD driver for reference, but I may have missed something. I do not have access to hardware.

#6

Updated by Ryo Murakawa almost 7 years ago

Albert Lee wrote:

It's possible this change is not sufficient for all 62xx devices. They seemed to be compatible based on using the FreeBSD driver for reference, but I may have missed something. I do not have access to hardware.

So I can test the beta driver because my laptop is used for the test. So if you need any kind of the information, please let me know.
I can get the information and test.

#7

Updated by Ryo Murakawa over 6 years ago

Ryo Murakawa wrote:

Albert Lee wrote:

It's possible this change is not sufficient for all 62xx devices. They seemed to be compatible based on using the FreeBSD driver for reference, but I may have missed something. I do not have access to hardware.

So I can test the beta driver because my laptop is used for the test. So if you need any kind of the information, please let me know.
I can get the information and test.

My Laptop is hp Spectre Envy14. This machine has Intel N6230. The output of scanpci is below:
pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x8086 device 0x088e
Intel Corporation Centrino Advanced-N 6235

I want to know how to create iwp driver with this device ID.

#8

Updated by Ryo Murakawa over 6 years ago

When will these forgot IDs be added and the fixed driver be included in OI?

Ryo Murakawa wrote:

Ryo Murakawa wrote:

Albert Lee wrote:

It's possible this change is not sufficient for all 62xx devices. They seemed to be compatible based on using the FreeBSD driver for reference, but I may have missed something. I do not have access to hardware.

So I can test the beta driver because my laptop is used for the test. So if you need any kind of the information, please let me know.
I can get the information and test.

My Laptop is hp Spectre Envy14. This machine has Intel N6230. The output of scanpci is below:
pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x8086 device 0x088e
Intel Corporation Centrino Advanced-N 6235

I want to know how to create iwp driver with this device ID.

#9

Updated by Lauri Tirkkonen almost 6 years ago

Albert Lee wrote:

It's possible this change is not sufficient for all 62xx devices. They seemed to be compatible based on using the FreeBSD driver for reference, but I may have missed something. I do not have access to hardware.

I have a 8086,0085 (subsystem 8086,1311) I could test with; care to share your patch? I couldn't find anything searching illumos-developer archives and I'd rather not run binaries off the interwebs.

#10

Updated by Albert Lee almost 6 years ago

I literally hex edited the binary from then-current OI as I did not have a lot of time when filing this bug. Doing this properly should be trivial.

#11

Updated by Albert Lee almost 6 years ago

Here is a quick patch that just assumes all 0x8* and 0x9* cards are the same.

#12

Updated by Albert Lee almost 6 years ago

Slightly more correct patch.

#13

Updated by Lauri Tirkkonen almost 6 years ago

The patched driver attaches fine, but upon dladm scan-wifi it outputs iwp_init(): failed to process init alive..

#14

Updated by Espen Martinsen almost 6 years ago

  • Status changed from New to Feedback

Hi,
I'm installing OI 151.a8 from scratch on a new Lenovo PC with this
builtin wireless:

pci bus 0x0003 cardnum 0x00 function 0x00: vendor 0x8086 device 0x0085
Intel Corporation Centrino Advanced-N 6205 [Taylor Peak]

As expected (after some reading) I did not see this card at all, but copied the
iwp-driver from https://www.illumos.org/issues/1756 to /kernel/drv/amd64/iwp, and
ran:
  1. update_drv -a -i '"pciex8086,85"' iwp

same as for the previous writer: driver attched, but outputs " WARNING: iwp_init(): failed to process init alive."

Modinfo says:
175 fffffffff893e000 79de8 166 1 iwp (Intel(R) PumaPeak driver(N))

  1. grep iwp driver_aliases
    iwp "pciex8086,008d"
    iwp "pciex8086,008e"
    iwp "pciex8086,422b"
    iwp "pciex8086,422c"
    iwp "pciex8086,4238"
    iwp "pciex8086,4239"
    iwp "pciex8086,85"
  2. dladm show-phys
    LINK MEDIA STATE SPEED DUPLEX DEVICE
    e1000g0 Ethernet up 100 full e1000g0
    iwp0 WiFi down 0 unknown iwp0
  1. dladm scan-wifi
    dladm: cannot scan link 'iwp0': operation failed

Please tell me if there is anything I can do to help someone update the driver to support this device. As a workaround, I can certainly use an usb-WL, but I would rather not.

#15

Updated by Espen Martinsen almost 6 years ago

Please tell me if there is anything I can do to help someone update the driver to support this device. As a workaround, I can certainly use an usb-WL, but I would rather not.

Hi,
the closed I've been now to get the 6205 working is with the newest iwp-driver from solaris11.
I'll guess this will work with solaris11, but it looks like is has some other (kernel?) bindings. here, I can plumb the interface, scan for networks, but it wont connect. (Well, I do not want to migrate to solaris11 anyway)

#16

Updated by Espen Martinsen over 2 years ago

note 21.nov 2016:
Suddenly I realized that my Centrino Advanced-N 6205 [Taylor Peak]
Was listed as a iwn -device,
turned on, and it works just fine.

$ pfexec dladm show-wifi
LINK STATUS ESSID SEC STRENGTH MODE SPEED
iwn0 connected esmWL24 wpa good g 48Mb

#17

Updated by Marcel Telka over 2 years ago

  • Is duplicate of Bug #1237: port Intel WifiLink 4965/100/1000/2000/5000/6000 driver added
#18

Updated by Marcel Telka over 2 years ago

  • Status changed from Feedback to Rejected

Also available in: Atom PDF