Project

General

Profile

Bug #1765

assert triggered in libzfs_import.c trying to import pool name beginning with a number

Added by Alexei Guliaev almost 8 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
zfs - Zettabyte File System
Start date:
2011-11-11
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

To reproduce this bug you just need to enter the "import" command with pool name satisfying the regexp [0-9][a-z]. No pool devices or files needed. Here is the example:

root@deimos:~# uname -a
SunOS deimos 5.11 3475e0a6829e i86pc i386 i86pc Solaris
root@deimos:~# 
root@deimos:~# ls
root@deimos:~# 
root@deimos:~# zpool import -d . 300M
Assertion failed: import->poolname == 0 || import->guid == 0, file ../common/libzfs_import.c, line 1451, function zpool_search_import
Abort (core dumped)
root@deimos:~# 
root@deimos:~# zpool import -d . 400M
Assertion failed: import->poolname == 0 || import->guid == 0, file ../common/libzfs_import.c, line 1451, function zpool_search_import
Abort (core dumped)
root@deimos:~# zpool import -d . 500M
Assertion failed: import->poolname == 0 || import->guid == 0, file ../common/libzfs_import.c, line 1451, function zpool_search_import
Abort (core dumped)
root@deimos:~# 

History

#1

Updated by Andrew Stormont over 7 years ago

  • Assignee set to Andrew Stormont

I think I see where the problem is.

#2

Updated by Albert Lee over 7 years ago

  • Subject changed from assert triggered in libzfs_import.c trying to import [0-9][a-z] to assert triggered in libzfs_import.c trying to import pool name beginning with a number

Updated bug title.

#3

Updated by Yuri Pankov over 7 years ago

Original title was correct:

deneb:root:~# zpool import 12
cannot import '12': no such pool available
deneb:root:~# zpool import 12a
Assertion failed: import->poolname == 0 || import->guid == 0, file ../common/libzfs_import.c, line 1467, function zpool_search_import
Abort (core dumped)

#4

Updated by Andrew Stormont over 7 years ago

The original title was misleading because the problem has nothing to do with regex.

#5

Updated by Robert Mustacchi about 6 years ago

  • Status changed from New to Resolved
  • Assignee changed from Andrew Stormont to Prasad Joshi
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

Resolved in 9edf9ebd727ac2046be0269a5e275785e2131bcb

Also available in: Atom PDF