Project

General

Profile

Bug #1782

Illumos tzdata update

Added by Michael Kosarev almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
Start date:
2011-11-16
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

Illumos has very old tzdata, same as OI151. Please update at least European tzdata, because otherwise all Russian users of OI get mad with crazy time in OI.
Here is script for quick tzdata update:

#!/bin/sh
  1. Disallow winter time for Moscow
    echo "Disable winter time for Moscow"
    sleep 3
    mkdir ./temp1
    cd ./temp1
    wget http://tx-us.lunar-linux.org/lunar/mirrors/tzdata2011n.tar.gz
    tar xzf tzdata2011n.tar.gz
    zic europe
    cd ..
    rm -rf ./temp1

Related issues

Is duplicate of illumos gate - Feature #1705: Update zoneinfo data to 2011mResolved2011-10-30

Actions

History

#1

Updated by Rich Lowe almost 8 years ago

  • Category changed from 35 to OS/Net (Kernel and Userland)
  • Assignee changed from OI Userland to OI illumos

Yuri fixed this in illumos under #1705. OI should either backport or refresh their illumos.

Given the apparent desire for a stable release, I'd backport.

#2

Updated by Jon Tibble almost 8 years ago

  • Status changed from New to Resolved
  • Target version set to oi_151_stable

Integrated into prestable0

Also available in: Atom PDF