Project

General

Profile

Bug #183

tr -dc in the netbeans stat script fails

Added by Ewald Ertl over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2010-09-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

The netbeans start script uses the following line

mem=`/usr/sbin/prtconf | grep Memory | /usr/bin/tr -dc '[0-9]'`

to determine the memory of the system.

I've compiled the lllumos version
root@solewer:/code/illumos-gate# hg id
1de0101e9338 tip

The result of the command above doesn't filter the ":" sign:

root@solewer:/code/illumos-gate# /usr/sbin/prtconf | grep Memory | /usr/bin/tr -dc '[0-9]'
: 3997

The output of the prtconf is:
root@solewer:/code/illumos-gate# /usr/sbin/prtconf | grep Memory
Memory size: 3997 Megabytes


Related issues

Is duplicate of illumos gate - Bug #132: tr breaks scriptsResolved2010-09-02

Actions

History

#1

Updated by Garrett D'Amore over 9 years ago

  • Project changed from site to illumos gate
#2

Updated by Garrett D'Amore over 9 years ago

  • Status changed from New to Closed

This is a duplicate of 132.. which was integrated already.

Also available in: Atom PDF