Project

General

Profile

Bug #1838

New ACPI code (20110527) breaks suspend/resume

Added by Gordon Ross almost 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Start date:
2011-12-01
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

The new ACPI code (Intel code drop 20110527) from Joyent OS-441,
proposed for integration in #1621, was observed to have regressions
in suspend/resume support. This issue tracks the follow-on work.

History

#1

Updated by Gordon Ross almost 9 years ago

Implementing the fixes re. "_PRW" methods as decribed in
https://www.illumos.org/issues/1621#note-5
has restored suspend/resume functionality.

There were other ACPI interface updates that were needed
as it turns out, in addition to evaluating "_PRW" methods:
+ Support access to EC space using width > 8 bits
+ Support EC GPE description as a "package".

#2

Updated by Gordon Ross almost 9 years ago

  • Status changed from New to Rejected

We decided to push all with one change set against #1621
so no need for this issue.

Also available in: Atom PDF