Project

General

Profile

Bug #1844

xen: "disk_link: invalid disk device number"

Added by Vitaliy Gusev almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
kernel
Start date:
2011-12-02
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

During boot VM under Xen hypervisor system got message:

"disk_link: invalid disk device number (2048)"

#2

Updated by Vitaliy Gusev over 8 years ago

Fixing patch information:

Parse Xen device number accordingly to Xen's commit
commit e951dcf324f7ce83da95264fa3c9a3e037269871
Author: Keir Fraser <>
Date: Fri Feb 5 10:36:17 2010 +0000
and message:
From: Ian Jackson <>
Subject: Xen vbd numbering
Date: Wed, 03 Feb 2010 16:51:47 GMT
Message-ID: <>
http://lists.xensource.com/archives/html/xen-devel/2010-02/msg00183.html
#3

Updated by Garrett D'Amore over 8 years ago

  • Category set to kernel
  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

Resolved in:

changeset: 13642:8107b374f945
tag: tip
user: Vitaliy Gusev <>
date: Tue Mar 20 15:29:39 2012 -0700
description:
1844 xen: "disk_link: invalid disk device number"
Reviewed by:
Reviewed by: Albert Lee <>
Reviewed by: Garrett D'Amore <>
Approved by: Garrett D'Amore <>

I'm calling this a kernel bug, even though the problem is really devfsadm which lives in user space. Its there to support the kernel though... :-)

Also available in: Atom PDF