Project

General

Profile

Actions

Bug #1869

closed

"zfs holds" is O(n^2)

Added by Matthew Ahrens over 12 years ago. Updated 1 day ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Start date:
2011-12-08
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:
External Bug:

Description

"zfs holds snap ..." is O(number snapshots listed ^2). For every snapshot, it gets all the holds on all of the named snapshots. This can be observed with truss.

The problem is that when the python code was removed, it was replaced with incorrect C code , which calls zfs_for_each() for every argument. But zfs_for_each() iterates over the arguments itself


Related issues

Has duplicate illumos gate - Bug #13905: zfs holds is quadraticClosedAndrew Stormont

Actions
Actions #1

Updated by Dan McDonald almost 3 years ago

  • Assignee set to Andrew Stormont

I think #13905 is a duplicate of this (and therefore this bug is now fixed).

Andrew Stormont --> could you please confirm/deny this?

Actions #2

Updated by Andrew Stormont almost 3 years ago

  • Has duplicate Bug #13905: zfs holds is quadratic added
Actions #3

Updated by Andrew Stormont almost 3 years ago

It certainly looks like 13905 is a duplicate.

Actions #4

Updated by Andy Fiddaman 1 day ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF