Project

General

Profile

Bug #1870

ctfconvert should accept DWARF objects with no type data

Added by Rich Lowe almost 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
tools - gate/build tools
Start date:
2011-12-09
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

ctfconvert believes that every object with DWARF data should have type data.
This is true of GCC, which seems to always include the basic types, but not of Studio. With studio, only types used in an object will exist in the DWARF. It turns out that we have approximately 25 objects which in most builds, don't actually contain any code at all (for varying reasons), so their lack of DWARF type information is not even somewhat incorrect.


Related issues

Is duplicate of illumos gate - Bug #2942: CTF tools need to handle files which legitimately lack dataResolved2012-06-28

Actions
Is duplicate of illumos gate - Bug #2978: ctfconvert still needs to ignore legitimately dataless files on SPARCResolved2012-07-09

Actions

History

#1

Updated by Rich Lowe almost 9 years ago

https://github.com/richlowe/illumos-gate/compare/tools/ctf-empty-cu contains a first stab at doing this in a way that still provides the useful behaviour of noticing people who have ommitted -g from their command line and things like that.

It is very lightly tested.

It is also insufficient to allow the use of DWARF and studio while building illumos. There are other (compiler) bugs currently preventing this. It is unclear if they can be worked around in the CTF tools.

#2

Updated by Rich Lowe about 8 years ago

  • Status changed from New to Closed

Also available in: Atom PDF