Project

General

Profile

Bug #1902

illumos-gate component libkmsagent FTBFS

Added by Andrew Stormont over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2011-12-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

libkmsagent makes use of ERR_remove_state which has been deprecated in OpenSSL 1.0 but it also defines OPENSSL_NO_DEPRECATED which causes a FTBFS. The attached patch works for me.


Files

libkmsagent.patch (483 Bytes) libkmsagent.patch Andrew Stormont, 2011-12-19 10:54 AM

History

#1

Updated by Andrew Stormont over 8 years ago

  • Status changed from New to Closed

Nevermind. I see we haven't added support for OpenSSL 1.0 yet.

Also available in: Atom PDF