Project

General

Profile

Bug #1959

Assertion failed: p->key == key, file ../port/locale/collate.c, line 199, function substsearch in el_{CY,GR}.UTF-8 locales

Added by Yuri Pankov over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
locale - data and messages
Start date:
2012-01-06
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

Collation data for el_{CY,GR}.UTF-8 seems to be broken, triggering the following assertion (simple testcase):

$ LC_COLLATE=el_CY.UTF-8 expr 1 + 1
Assertion failed: p->key == key, file ../port/locale/collate.c, line 199, function substsearch
Abort (core dumped)
$ LC_COLLATE=el_GR.UTF-8 expr 1 + 1
Assertion failed: p->key == key, file ../port/locale/collate.c, line 199, function substsearch
Abort (core dumped)

The quick fix is backport the sources for these locales from the latest CLDR release.


Related issues

Related to illumos gate - Bug #1569: localedef mishandles some multibyte localesResolvedGarrett D'Amore2011-09-26

Actions
Related to illumos gate - Bug #852: Update data files for localedef UTF-8 locales from CLDR v2.0.1ResolvedGarrett D'Amore2011-03-25

Actions
#1

Updated by Yuri Pankov over 9 years ago

  • Assignee deleted (Yuri Pankov)
#2

Updated by Garrett D'Amore about 9 years ago

  • Assignee set to Garrett D'Amore

New locale data is indeed needed, but I think the problem is a root bug in localedef itself. Yao found some of these a while back. See 1569.

#3

Updated by Garrett D'Amore about 9 years ago

  • Status changed from New to Resolved

This was resolved by the following, I believe:

changeset: 13591:0b83d70b9fe5
tag: tip
user: Garrett D'Amore <>
date: Fri Feb 03 16:50:30 2012 -0800
description:
852 Update data files for localedef UTF-8 locales from CLDR v2.0.1
1569 localedef mishandles some multibyte locales
Reviewed by: Richard Lowe <>
Reviewed by: Gordon Ross <>
Reviewed by: John Sonnenschein <>
Reviewed by: Robert Mustacchi <>
Approved by: Richard Lowe <>

Also available in: Atom PDF