Project

General

Profile

Bug #198

raidz2 reading is slow

Added by Petri Kunnari about 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2010-09-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

History

#1

Updated by Garrett D'Amore about 9 years ago

Have you verified this with current illumos?

Be advised that the synchronous nature of NFS combined with raidz means that your I/Os will usually be restricted in performance to the speed of the slowest spindle in your array.

#2

Updated by Petri Kunnari about 9 years ago

Garrett D'Amore wrote:

Have you verified this with current illumos?

Be advised that the synchronous nature of NFS combined with raidz means that your I/Os will usually be restricted in performance to the speed of the slowest spindle in your array.

Referring chat in irc..
This points more to nvidia chipset/driver problem.
Best quess is nge driver when use full nvidia ide,sata,network hw configuration and drivers.
Currently cannot verify as recently changed motherboard

#3

Updated by Petri Kunnari about 9 years ago

Petri Kunnari wrote:

Garrett D'Amore wrote:

Have you verified this with current illumos?

Be advised that the synchronous nature of NFS combined with raidz means that your I/Os will usually be restricted in performance to the speed of the slowest spindle in your array.

Referring chat in irc..
This points more to nvidia chipset/driver problem.
Best quess is nge driver when use full nvidia ide,sata,network hw configuration and drivers.
Currently cannot verify as recently changed motherboard

HI
got email update from oracle bug database.
-------
Change Request ID: 6977913

Synopsis: RAID-Z/mirror hybrid allocator

Product: solaris
Category: kernel
Subcategory: zfs
Type: RFE
Subtype: Performance
Status: 10-Fix Delivered
Substatus:
Priority: 2-High
Introduced In Release: solaris_nevada
Introduced In Build: snv_27
Responsible Engineer: <User 1-5Q-9981>
Keywords:

Normally mirror vdevs contain mirrored data, RAID-Z vdevs contain RAID-Z data, etc. However, for latency-sensitive metadata, we can use a mirrored layout across the children of a RAID-Z vdev. This ensures that such metadata can be read in a single I/O.

  • (#1 of 1): 2010-08-17 23:05:26 GMT+00:00 <User 1-5Q-9981>

=== Public Comments ========================================================

=== Workaround =============================================================

=== Additional Details =====================================================
Targeted Release: solaris_nevada
Commit To Fix In Build: snv_148
Fixed In Build: snv_148
Integrated In Build: snv_148
Verified In Build:
See Also: 6608518, 6937725
Duplicate of:
Hooks:
Hook1:
Hook2:
Hook3:
Hook4:
Hook5:
Hook6:
Program Management:
Root Cause:
Fix Affects Documentation: No
Fix Affects Localization: No
-----------

#4

Updated by Garrett D'Amore about 9 years ago

  • Status changed from New to Feedback

Yes, I know about the hybrid allocator. Unfortunately, we don't have access to that code.

At the same time, I'm unconvinced that this is necessarily the source of your problem. Are you just repeating the bug from Bonwick, or did you have specific performance problems backed by numbers?

#5

Updated by Garrett D'Amore about 6 years ago

  • Difficulty set to Medium
  • Tags set to needs-triage

Closing this. No feedback from submitter. Its a dead issue.

#6

Updated by Garrett D'Amore about 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF