Project

General

Profile

Bug #1983

sshd problems

Added by Hugo Fraga over 9 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Start date:
2012-01-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
sshd
Gerrit CR:

Description

Greetings , hopefully someone can help me as i am at a total loss and feeling highly frustrated for not being able to understand what's happening.

So i've been a linux user and recently tried openindiana and fell in love with it , i downloaded openindiana 151a and noticed that every time i would connect to the ssh server for the first time after installation and every first time after rebooting i would get a 2-3 second delay before getting password prompt.

This started worrying me so i went to irc and people said it had to be a dns issue , so i added the following to sshd_config :

LookupClientHostnames no
VerifyReverseMapping no

But the delay persisted , so then i saw that there was a illumos joyment patch for sshd to make sure that it wasn't really trying to do the reverse mapping and i patched illumos-gate sshd and recompiled it and replaced the default sshd and still nothing.

I've tried on 3 different machines with very different hardware specs , tried even without even setting up a network interface and just typing ssh localhost from the server itself and i still got the delay the first time i did
that , i notice that the hard drive reads a lot for that first time , as in if it's loading modules or so but when i asked people said they didn't have this delay for the first time after reboot etc.

My machines have decent hardware , core i7 920 on the flagship one where i first experienced the issues , a hp micro server with a amd dual core and my iMac which i also installed openindiana on just to make sure it wasn't some hardware issue.

This happens on solaris 11 as well , does not happen on nexenta core or nexenta stor , happens on illumian , doesn't happen on the linux ones.

Any help would be greatly appreciated , here is a sshd -ddd log before i had added the reverselookup no etc since i can't recall how to output it to a file was it sshd -ddd 2&>1 > /tmp/blah or ? sigh :( can't recall but that log shows exactly the same symptoms as it does now with the dns lookup off , it halts on the "Waiting for monitor" part.

Thank you very much in advance , hope we can figure out what this is , unless this is normal of course but everyone i asked said it wasn't.

http://pastebin.com/x12Lb9Tv sshd server log

Also available in: Atom PDF