Project

General

Profile

Bug #2029

gtkam crashing

Added by r a over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2012-01-24
Due date:
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
gtkam

Description

Late time I used gtkam on OpenIndiana to download photos from my Nikon L20 digital camera it worked perfectly and had been working for months. However when I tried to download photos today using gtkam, it crashes as it attempts to load /usr/lib/libgphoto2/2.4.9.1
See the attached truss of gtkam as it crashes.


Files

truss.gtkam (332 KB) truss.gtkam truss -leaf gtkam r a, 2012-01-24 07:49 PM
truss.gtkam (331 KB) truss.gtkam r a, 2012-05-02 03:43 PM
building-libgphoto2-2.5.0.txt (20.2 KB) building-libgphoto2-2.5.0.txt r a, 2012-11-01 08:35 AM
gphoto2.truss (21 KB) gphoto2.truss r a, 2013-03-27 10:29 PM

History

#1

Updated by Ryo Murakawa over 8 years ago

  • Assignee set to Ryo Murakawa
#2

Updated by Ryo Murakawa over 8 years ago

  • Assignee changed from Ryo Murakawa to OI Userland
  • Tags changed from needs-triage to gtkam
#3

Updated by r a over 8 years ago

Upgraded to OpenIndiana Development oi_151.1.3 X86 (powered by illumos) Assembled 24 March 2012Upgrade OI but problem still remains. Have attached a new truss of gtkam and the hanging and crash when loading /usr/lib/libgphoto2/2.4.9.1

#4

Updated by r a almost 8 years ago

  • Status changed from New to Feedback

Upgraded to oi_151a7 and tried to use gtkam and cli gphoto commands to download pictures from my Nikon camera but both methods fail with an application crash.

#5

Updated by r a almost 8 years ago

Tried to build libgphoto2-2.5.0 but it complained about the libusb library, as it requires a version of libusb that is version 1.0.0 or later. Checking the version information in package manager, the version shipped with OpenIndiana is version 0.1.8. The current release of libusb from http://www.libusb.org/ is version 1.0.9.

Can base version of libusb be upgraded to v1.0.9

#6

Updated by r a almost 8 years ago

The previous post is incorrect as OpenIndiana is using http://sourceforge.net/apps/trac/openusb which is MT-safe. However the current version is currently v1.1.7 which is still more up recent that the current version.

#7

Updated by r a over 7 years ago

Upgraded to OpenIndiana b151a7 when I start the Digital Camera Browser it just crashes.

#8

Updated by r a over 7 years ago

Connected camera via Belkin Digiconnect 5 port USB 2.0 PCI card the problem remains even when there is no digital camera connected.

#9

Updated by r a over 7 years ago

Add truss -leaf -o gphoto2.truss file

#10

Updated by r a about 7 years ago

Hi,

Upgraded to oi151a8_hipster and the problem of using gtkam crashing is still occuring.

#11

Updated by Ken Mays about 7 years ago

  • Category set to Desktop (JDS)
  • Target version deleted (oi_151_stable)
  • % Done changed from 0 to 100

Tested gtkam 0.1.18/gphoto2 2.4.10 functionality with Canon EOS 5D Mark III using oi_151a8. Camera was detected and photos were downloaded properly for viewing. No major crash issues with app on all functions. If camera initialization issues occured during rescan, I just reloaded the app or I replugged the USB cable from the camera into the computer. Problems solved.

#12

Updated by Ken Mays almost 7 years ago

  • Status changed from Feedback to Closed
  • Assignee changed from OI illumos to OI JDS
  • Estimated time set to 1.00 h

Issue resolved on oi_151a8.

Also available in: Atom PDF