Project

General

Profile

Bug #205

Crash in package manager

Added by Michael Widmann almost 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
PKG (Image Packaging System)
Target version:
Start date:
2010-09-15
Due date:
2011-09-14
% Done:

0%

Estimated time:
40.00 h
Difficulty:
Medium
Tags:
needs-triage

Description

hlerdetails:
Traceback (most recent call last):
File "/usr/lib/python2.6/vendor-packages/pkg/gui/installupdate.py", line 580, in __on_cancelcreateplan_clicked
if self.api_o.can_be_canceled() and self.operations_done_ex == False:
AttributeError: 'InstallUpdate' object has no attribute 'api_o'

Liste der konfigurierten Herausgeber:
P O openindiana.org (http://pkg.openindiana.org/dev/)
E O opensolaris.org (http://pkg.openindiana.org/legacy/)

Paketversion:
552262a56a9a


Related issues

Has duplicate OpenIndiana Distribution - Bug #283: Package manager fails after search updateClosed2010-09-29

Actions

History

#1

Updated by none none almost 9 years ago

Please add the steps to reproduce it.

#2

Updated by Michael Kosarev over 8 years ago

Steps to reproduce:
1. Open Package Manager
2. Push "Updates" button, after checking updates, package manager won't find any update
3. Press "Close" button
4. Bang, we have crash:

Error details:
Traceback (most recent call last):
File "/usr/lib/python2.6/vendor-packages/pkg/gui/installupdate.py", line 580, in __on_cancelcreateplan_clicked
if self.api_o.can_be_canceled() and self.operations_done_ex == False:
AttributeError: 'InstallUpdate' object has no attribute 'api_o'

List of configured publishers:
P O openindiana.org (http://pkg.openindiana.org/dev/)
E O kdeips-dev (http://solaris.bionicmutton.org/pkg/4.5.3/)
E O opensolaris.org (http://pkg.opensolaris.org/dev/)

pkg version:
552262a56a9a

#3

Updated by Albert Lee over 8 years ago

  • Status changed from New to Feedback

Can't reproduce on oi_148.

#4

Updated by Matt Wilby over 8 years ago

  • Category set to Desktop (JDS)
  • Assignee set to Matt Wilby
  • Priority changed from High to Normal

Can you let us know if you are still experiencing this issue in oi148?

#5

Updated by Ken Mays almost 8 years ago

  • Due date set to 2011-09-14
  • Category changed from Desktop (JDS) to PKG (Image Packaging System)
  • Status changed from Feedback to Resolved
  • Assignee changed from Matt Wilby to OI PKG
  • Target version set to oi_151_stable
  • Estimated time set to 40.00 h
  • Difficulty set to Medium
  • Tags set to needs-triage

Michael - We've migrate all resolution work to the oi_151a stable project and dev-il repository. Issue was resolved for oi_148 through recent updates, but please migrate to oi_151(a).

#6

Updated by Ken Mays over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF