Project

General

Profile

Bug #2051

failed to boot up with Sandy Bridge

Added by stephen wong over 8 years ago. Updated almost 8 years ago.

Status:
New
Priority:
Urgent
Assignee:
-
Category:
-
Start date:
2012-02-01
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

We are using OpenIndiana build 151a. The hardware has Sandy Bridge CPU.
The system fails to boot after the splash screen shows up. Please see the attached screen shot. It is related to apix.

I found a comment at the release notes. It says that I have to add this at /etc/system
"set apix:apic_timer_preferred_mode = 0x0"

http://wiki.openindiana.org/oi/oi_151a+Release+Notes

Also, issue 1723 looks like related too.
https://www.illumos.org/issues/1723
It suggests to add this "set apix_enable = 0" to /etc/system

However, I tried both of them, either one of them, still get the same failure. They reported that the workaround worked fine for them. But not for me. Not sure I am dealing with different problem or not.

Can somebody suggest us what to do? We can provide more information if necessary.

Thanks,


Files

2.jpg (188 KB) 2.jpg stephen wong, 2012-02-01 04:50 AM

History

#1

Updated by Jon Strabala over 8 years ago

Hi Stephan,

Please post the start of your stack trace (otherwise no one knows what your issue is). So I am just going to take a guess here.

FYI - if it fails to boot it might never read your /etc/system file. Next you need to follow the instructions in issue 1723 and use the kernel debugger if that is truly your problem.

So is the live CD is failing? (you never installed) I assume you issue is on the live CD ?

In grub you can edit the kernel line to go into the kernel debugger e.g. add -kd to the grub line to the kernel line of the text boot option. I think it will look some thing like the below (this is what issue 1723 alludes too).

kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS -kd

the hit 'b' to boot form grub, when you hit your first break point type the following two lines:

apix_enable /W 0
:c

If that works then you have to keep ding this process until you install the system onto disk and can edit your /etc/system file.

Also you mention that "set apix:apic_timer_preferred_mode = 0x0", I don't recall if you can set this symbol with your other fixup (above) in the kernel by adding one additional command at your break point.

apix_enable /W 0
apic_timer_preferred_mode /W 0
:c

but I do think that 'apic_timer_preferred_mode' only caused a slow CPU kernel creep issue #1333 (fixed in prestable0 and illumos-gate nightly) - I spent a lot of time on this one myself as it was a show stopper for me.

Looking at the related issue to 1723, e.g. 1834, - you might also have a bit of luck is you turn off hyper threading in your BIOS (but this is not proven).

#2

Updated by stephen wong over 8 years ago

Thanks for the quick reply. I will get the stack trace properly.

The live CD is ok and I actually install 151a to my SATA disk over it. When I start the server with that SATA disk, I get to grub and then I select OI 151a and after a moment, I get that stack trace and system reboots.

But I found that my problem is not with Sandy Bridge. It is very likely related to Intel Patsburg support. I don't think 151a support this, is that correct?

thanks,
Stephen

#3

Updated by stephen wong over 8 years ago

I executed the workaround you mentioned about debugger at the grub line. Then turn off apix module. The system can boot now. So you are right as the system failed before reaching the /etc/system. By the way, "apic_timer_preferred_mode /W 0" is not allowed as the symbol is not loaded at that time. We just did "apix_enable /W 0".

It has no driver associated to the SAS port of Patsburg, and need workaround on SATA, so it is not supporting Patsburg fully. Anyway, this is already a big help for us to move on.

By the way, what do we miss by disabling apix module? Performance or some features?

Thank you very much.

Stephen

#4

Updated by Jon Strabala over 8 years ago

Stephen.

Glad you got your Sandy Bridge with a C600 (Patsburg) chipset up, I run a C204 (Cougar Point) chipset on my rig and have no issues with SATA drivers.

Now as to "the system failed before reaching the /etc/system" remember if you add the correctly line to this file e.g. "set apix_enable = 0" and do a reconfiguration reboot it should now boot without the kernel debugger commands. Also I believe you can apply this fix right after an install but before you click the install reboot button

IDEA idea here - put an optional  "fix errata" button in the last installer screen, e.g. 
prior to a reboot #1723 implies we could automatically test for the condition - or 
other known conditions - and sort of patch up /etc/system and/or other files like 
/etc/driver_aliases - the attached fix errata script could also be "downloadable", 
accessible from a thumb drive, or https source.  As there are not that many releases
of openindina this would give people a fighting change of dealing turning up
"newer" HW if there is a discovered workaround.

FYI, if you see a slow CPU creep in the kernel you will need to add this "set apix:apic_timer_preferred_mode = 0x0" to /etc/system, upgrade to oi151 prestable0 (or the final stable due out very soon), or run the nightly illumos-gate to fix #1333, e.g. deadline support.

You are probably running in IDE legacy mode if your system can not find a SATA driver, I couldn't tell you the performance impact. But for this information your best bet is to go to http://webchat.freenode.net/ channel #illumos and where you will get much better input. If you discuss your issues and success in the #illumos chat it might escalate a bit of development to specifically address your chipset (this is far beyond my "pay grade").

In fact in an IRC chat archive [http://echelog.matzon.dk/logs/browse/oi-dev/1328137200] you will even see Patsburg being discussed by a few primary illumos developers in the #illumos channel.

Cheers,
Jon

#5

Updated by Albert Lee almost 8 years ago

  • Project changed from site to illumos gate

Also available in: Atom PDF