Project

General

Profile

Bug #207

Problems upgrading from snv_134

Added by Karl Dag Gursli almost 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
PKG (Image Packaging System)
Target version:
-
Start date:
2010-09-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

Installed OpenSolaris snv_134 from the osol-dev-134-x86.iso from genunix.org in an vmware esx virtual machine.

Followed the instructions from http://wiki.openindiana.org:8080/display/oi/Installing+or+Upgrading.
By using these steps: * pfexec pkg set-publisher --non-sticky opensolaris.org * pfexec pkg set-publisher -P -g http://pkg.openindiana.org/dev openindiana.org * pfexec pkg uninstall entire * pfexec pkg image-update
When i try the last step it fails with this error message:

admin@svg-p-illumos01:~$ pfexec pkg image-update
DOWNLOAD                                  PKGS       FILES    XFER (MB)
mail/thunderbird                       345/770 21257/39908  254.1/519.6  

Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

Framework error: code: 6 reason: Couldn't resolve host '~0~pkg-origin.openindiana.org'
URL: 'http://pkg.openindiana.org/dev/file/0/c5df73fea1fb6f63f0f17cf5e996e8525fc1a4f4'. (happened 4 times)

admin@svg-p-illumos01:~$ uname -a
SunOS svg-p-illumos01 5.11 snv_134 i86pc i386 i86pc Solaris
admin@svg-p-illumos01:~$ 


Related issues

Related to OpenIndiana Distribution - Bug #236: Open Office fails to installClosed2010-09-20

Actions

History

#1

Updated by Eldee Stephens almost 9 years ago

i should also point out that this is not necessarily file-dependent. i eventually gave up on the image-update method, downloaded the repo, and fired it up on one of my spare boxes.

this looks like an issue at the content distribution level. every time i hit this, regardless of file, it was always trying to resolve ~0~pkg-origin.openindiana.org.

just wanted to confirm the issue.

-- eldee

#2

Updated by Bryan Biedenkapp almost 9 years ago

Eldee,

What does "pfexec pkg publisher" show for you?

-- Bryan

#3

Updated by Oscar del Rio almost 9 years ago

Similar issue here. image-update fails trying to resolve '~0~pkg.openindiana.org' (without 'origin' as originally reported).

$ uname -a
SunOS 5.11 snv_134 i86pc i386 i86pc
$ pfexec pkg set-publisher --non-sticky opensolaris.org
$ pfexec pkg set-publisher -p http://pkg.openindiana.org/dev
$ pfexec pkg set-publisher -P openindiana.org
$ pfexec pkg uninstall entire
PHASE ACTIONS
Removal Phase 54/54
PHASE ITEMS
Reading Existing Index 8/8
Indexing Packages 1/1
Deleting content cache
$ pfexec pkg image-update
DOWNLOAD PKGS FILES XFER (MB)
mail/thunderbird 368/807 23205/43056 300.0/609.2

Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

1: Framework error: code: 6 reason: Couldn't resolve host '~0~pkg.openindiana.org'
URL: 'http://pkg.openindiana.org/dev/file/0/c5df73fea1fb6f63f0f17cf5e996e8525fc1a4f4'.
2: Invalid content path usr/lib/thunderbird/thunderbird-bin: chash failure: expected: 64fd9c1561c244e0563dfc675dbd3a8c3c86f469 computed: 9179b65e28cc293105c6368ee818f1729eb7f991. (happened 3 times)

$ pfexec pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org (non-sticky) origin online http://pkg.opensolaris.org/dev/
contrib origin online http://pkg.opensolaris.org/contrib/
extra origin online https://pkg.sun.com/opensolaris/extra/

#4

Updated by Karl Dag Gursli almost 9 years ago

I manged to the OpenIndiana installed early this morning(CET), but now I can't get it installed. There has been some talking on irc and posting in the mailing lists that they are struggling with performance.
Look at this mail from Alasdair: http://openindiana.org/pipermail/openindiana-discuss/2010-September/000152.html

So I think they are still struggling with performance.

Karl

#5

Updated by Michael Rennecke almost 9 years ago

I have a similar Problem:

rennecke@walhalla ~ % pfexec pkg image-update
DOWNLOAD                                  PKGS       FILES    XFER (MB)
mail/thunderbird                       190/838  7945/40200  131.8/648.9  

Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

Framework error: code: 18 reason: transfer closed with 13603900 bytes remaining to read
URL: 'http://pkg.openindiana.org/dev/file/0/c5df73fea1fb6f63f0f17cf5e996e8525fc1a4f4'. (happened 4 times)

The following proxy configuration is set in the environment:

http_proxy: http://www-cache.uni-halle.de:3128/

pfexec pkg image-update  43.18s user 1.09s system 68% cpu 1:05.10 total
1 rennecke@walhalla ~ % 

This are my publishers:

1 rennecke@walhalla ~ % pkg publisher
PUBLISHER                             TYPE     STATUS   URI
openindiana.org          (preferred)  origin   online   http://pkg.openindiana.org/dev/
opensolaris.org          (non-sticky) origin   online   http://pkg.openindiana.org/legacy/
contrib.opensolaris.org               origin   online   http://pkg.opensolaris.org/contrib/
extra                                 origin   online   https://pkg.sun.com/opensolaris/extra/
pending                               origin   online   http://pkg.opensolaris.org/pending/
rennecke@walhalla ~ % uname -a
SunOS walhalla 5.11 snv_134 i86pc i386 i86pc

#6

Updated by Karl Dag Gursli almost 9 years ago

Have found a possible solution, and tested it once.

Add a another preferred publisher for openindiana.org, the italian mirror:

pfexec pkg set-publisher -g http://pkg.corp.it/oi_dev openindiana.org

Publishers:

PUBLISHER                             TYPE     STATUS   URI
openindiana.org          (preferred)  origin   online   http://pkg.corp.it/oi_dev/
openindiana.org          (preferred)  origin   online   http://pkg.openindiana.org/dev/
opensolaris.org          (non-sticky) origin   online   http://pkg.opensolaris.org/dev/
ips.homeunix.com                      origin   online   http://opensolaris.homeunix.com:10906/
opensolaris-contrib                   origin   online   http://pkg.opensolaris.org/contrib/
opensolaris-extra                     origin   online   https://pkg.sun.com/opensolaris/extra/
sunfreeware                           origin   online   http://pkg.sunfreeware.com:9000/

-- Karl

#7

Updated by Guido Berhörster almost 9 years ago

  • Status changed from New to Feedback

There are two different issues involved here, corrupt files in the CDN cache and problems connecting to the CDN servers.
We have already fixed several of the former, please try again and report any additional corrupt files.

Also note that it is recommended to uninstall packages from third party repositories before upgrading.

#8

Updated by Oscar del Rio almost 9 years ago

Another possibly corrupted file?

$ pfexec pkg image-update
DOWNLOAD PKGS FILES XFER (MB)
library/python-2/python-twisted-26 393/807 25318/43056 338.8/609.2 $<3>

Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

http protocol error: code: 404 reason: Not Found
URL: 'http://pkg.openindiana.org/dev/file/0/6e181bbdaff34937ba26d7180cfd5d2b303bf646'. (happened 4 times)

#9

Updated by Guy Woolley almost 9 years ago

I had similar problems with image-update failing at thunderbird/mail; a switch to the italian mirror identified in Comment 6 seems to have worked, but:

1) my keyboard is now not right; most characters are mapped correctly but half a dozen are permuted over the keys and two are missing. Maybe an "Italian keyboard" (?) but so far I can't change it.

I've tried
#svccfg
svc: /system/keymap:default > setprop keymap/layout = UK-English

but that had no immediate effect, and no effect after reboot.

2) Everything else seems OK except that one service has been put in maintenance state:

system/filesystem/zfssnap-roleadd:default

So while most of the filesystem is there, if I attempt to point at my HOME folder in Gnome the system crashes.

Sorry if this is the wrong place to report these problems

#10

Updated by Albert Lee over 8 years ago

Guy Woolley wrote:

1) my keyboard is now not right; most characters are mapped correctly but half a dozen are permuted over the keys and two are missing. Maybe an "Italian keyboard" (?) but so far I can't change it.

I've tried
#svccfg
svc: /system/keymap:default > setprop keymap/layout = UK-English

but that had no immediate effect, and no effect after reboot.

See bug #203.

2) Everything else seems OK except that one service has been put in maintenance state:

system/filesystem/zfssnap-roleadd:default

This is a known bug, #234. It's safe to delete the service or just ignore it.

So while most of the filesystem is there, if I attempt to point at my HOME folder in Gnome the system crashes.

This a new problem we aren't aware of and isn't related to the previous one. Can you file a new bug describing how to reproduce it? I can give you instructions on getting a stack trace from the crash.

Sorry if this is the wrong place to report these problems

Please click the "New issue" link on the left.

#11

Updated by Julian Wiesener about 8 years ago

  • Status changed from Feedback to Closed

i close this bug because we got no feedback for >6months and also it is obviously related to our early cdn problems

Also available in: Atom PDF