Project

General

Profile

Feature #208

Support GPT

Added by Matthias Rampke almost 9 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
-
Start date:
2010-09-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

OpenIndiana should be able to read/write and be installed to GPT-partitioned disks. Right now the Live ISO does not recognise them, i.e. GParted shows the disk as empty, parted as unrecognized format. The installer proposes to resize the GPT protective MBR partition.

It would probably be advisable to use the Solaris partition types, see e.g. Wikipedia.

History

#1

Updated by Julian Wiesener about 8 years ago

  • Category set to Caiman (Installer)
  • Assignee set to OI Caiman
#2

Updated by Bayard Bell over 7 years ago

  • Category changed from Caiman (Installer) to OS/Net (Kernel and Userland)
  • Status changed from New to Feedback
  • Assignee changed from OI Caiman to OI illumos
  • Priority changed from Normal to Low
  • Difficulty set to Medium

This isn't simply a Caiman issue: the illumos kernel doesn't boot off GPT and/or EFI. This needs to be addressed in the upstream before we think about installer support.

#3

Updated by Aurélien Larcher about 2 years ago

  • Status changed from Feedback to Closed
#4

Updated by Nikola M. about 2 years ago

I can confirm I can't auto mount GPT-formatted USB drive
Probably this is related and could be duplicate of https://www.illumos.org/issues/8065
but dont't understand why closing without fix. Or it is fixed in illumos. (where?)

Also available in: Atom PDF