Project

General

Profile

Actions

Feature #2100

open

update HAL to 0.5.14

Added by Milan Jurik over 9 years ago. Updated almost 9 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
cmd - userland programs
Start date:
2012-03-28
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Currently Illumos integrates HAL based on version 0.5.8, the last version is 0.5.14. Some newer software (e.g. pulseaudio) depends on newer HAL.


Subtasks 2 (0 open2 closed)

Bug #2555: libhal does not unref some messagesResolvedMilan Jurik2012-03-28

Actions
Feature #2950: sync hald-runner with upstreamResolvedMilan Jurik2012-06-30

Actions

Related issues

Related to illumos gate - Bug #2071: "libhal_device_free_changeset" function mem-leeks.ResolvedMilan Jurik2012-02-03

Actions
Related to illumos gate - Bug #2666: libhal should be more carefull about function parametersResolvedMilan Jurik2012-05-01

Actions
Related to illumos gate - Bug #2667: libhal can leak memory if realloc() failsResolvedMilan Jurik2012-05-01

Actions
Related to illumos gate - Feature #2919: add hal-set-property --directIn ProgressMilan Jurik2012-06-23

Actions
Actions #1

Updated by Andrew Stormont over 9 years ago

Our version of HAL is actually closer to 0.5.12 in my experience (I think it has had a few things backported) and in 99% of cases will work fine if you modify the software you are trying to build against to look for 0.5.8 instead. I can also say from firsthand experience that Pulseaudio will work with our version of HAL just fine.

Actions #2

Updated by Milan Jurik over 9 years ago

Even if we are closer to 0.5.12, we are still setting 0.5.8:

http://src.illumos.org/source/xref/illumos-gate/usr/src/cmd/hal/Makefile.hal#28

We should be fresh.

Actions #3

Updated by Milan Jurik about 9 years ago

  • Assignee set to Milan Jurik
  • Tags deleted (needs-triage)
Actions

Also available in: Atom PDF