Project

General

Profile

Bug #2129

interrupt increase on some Sandy Bridge CPUs

Added by Peter LaCasse over 7 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
kernel
Start date:
2012-02-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

This problem occurs on 151a and with illumos sources downloaded Thursday Feb 9 (compiled with gcc).

The symptoms of this problem are very similar to those of issue #1333, but the solution(s) offered in that discussion do not resolve it. As reported by mpstat, values in the intr column and sys column steadily increase (mostly on CPU 0 but to a lesser degree on other CPUs) until, after 4 days or so, dtrace hangs the system.

I've attached mpstat-20120210-t2-nightly.txt to show how the problem progresses over time. Here's the final measured minute before the hang that was prompted by dtrace:

CPU minf mjf xcal intr ithr csw icsw migr smtx srw syscl usr sys wt idl
0 8 0 9 1161878 133 77 1 4 2 0 16 2 39 0 59
1 2 0 0 392319 22 102 0 5 2 0 30 0 13 0 87
2 1 0 0 385365 18 97 0 5 2 0 17 0 12 0 87
3 3 0 0 415978 23 102 0 5 2 0 18 0 13 0 87

intrstat says that the interrupts are not due to a hardware device.

This system has an Intel i7-2600K with hyperthreading turned off in the BIOS.

The issue happens on some Sandy Bridge CPUs and not others. It happens with Intel motherboards such as DH61DL, DH61CR, and DQ67OW. It happens with these CPUs: i7-2600K, i3-2120, i3-2100, G620. It does not happen with these CPUs: i7-2600, i5-2400. According to ark.intel.com the difference between CPUs is that the ones that do not show the problem have these features:

Intel vPro Technology
Intel Virtualization Technology for Directed I/O (vt-d)
Intel Trusted Execution Technology

Unfortunately I don't have the luxury of using a CPU that doesn't show the problem.

I've tried turning off or on everything in the BIOS that's configurable and I've tried the solutions referred to in issue #1333, #423, and #1723 such as "set apix:apic_timer_preferred_mode = 0x0". I've also tried some bootenv.rc options such as acpi-user-options 2, acpi-user-options 8, intel-iommu no, and disable-ehci true, with no apparent effect.

I'll add more information as it becomes available. Is there anything specifically that would help?


Files

mpstat-20120210-t2-nightly.txt (2.28 MB) mpstat-20120210-t2-nightly.txt output of mpstat 60 Peter LaCasse, 2012-02-14 10:33 PM

Related issues

Is duplicate of illumos gate - Bug #1333: High kernel cpu usage & dtrace hang on idle systemResolved2011-08-04

Actions

History

#1

Updated by Peter LaCasse over 7 years ago

  • Status changed from New to Feedback

I am happy to report that the issue does not occur with release 151a2. Please feel free to mark it closed.

#2

Updated by Rich Lowe over 7 years ago

  • Category set to kernel
  • Status changed from Feedback to Rejected

I'm expecting that this was thus #1333

Also available in: Atom PDF