Project

General

Profile

Bug #2156

Wi-Fi doesn't work on Toshiba Satellite L645

Added by daniel kho over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Drivers
Target version:
-
Start date:
2012-02-20
Due date:
2012-03-30
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
broadcom

Description

Hi, after installing OI-151a on my Toshiba Satellite L645, I found that the Wi-Fi device is not working.

History

#1

Updated by Milan Jurik over 7 years ago

  • Status changed from New to Feedback

Please, add output from:

scanpci

dladm show-phys

#2

Updated by daniel kho over 7 years ago

Hi Milan, here it is:
root@swiftlet:~# scanpci

pci bus 0x0000 cardnum 0x00 function 0x00: vendor 0x8086 device 0x0044
Intel Corporation Core Processor DRAM Controller

pci bus 0x0000 cardnum 0x02 function 0x00: vendor 0x8086 device 0x0046
Intel Corporation Core Processor Integrated Graphics Controller

pci bus 0x0000 cardnum 0x16 function 0x00: vendor 0x8086 device 0x3b64
Intel Corporation 5 Series/3400 Series Chipset HECI Controller

pci bus 0x0000 cardnum 0x1a function 0x00: vendor 0x8086 device 0x3b3c
Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller

pci bus 0x0000 cardnum 0x1b function 0x00: vendor 0x8086 device 0x3b56
Intel Corporation 5 Series/3400 Series Chipset High Definition Audio

pci bus 0x0000 cardnum 0x1c function 0x00: vendor 0x8086 device 0x3b42
Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1

pci bus 0x0000 cardnum 0x1c function 0x04: vendor 0x8086 device 0x3b4a
Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5

pci bus 0x0000 cardnum 0x1c function 0x05: vendor 0x8086 device 0x3b4c
Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6

pci bus 0x0000 cardnum 0x1d function 0x00: vendor 0x8086 device 0x3b34
Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller

pci bus 0x0000 cardnum 0x1e function 0x00: vendor 0x8086 device 0x2448
Intel Corporation 82801 Mobile PCI Bridge

pci bus 0x0000 cardnum 0x1f function 0x00: vendor 0x8086 device 0x3b09
Intel Corporation Mobile 5 Series Chipset LPC Interface Controller

pci bus 0x0000 cardnum 0x1f function 0x02: vendor 0x8086 device 0x3b29
Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller

pci bus 0x0000 cardnum 0x1f function 0x03: vendor 0x8086 device 0x3b30
Intel Corporation 5 Series/3400 Series Chipset SMBus Controller

pci bus 0x0000 cardnum 0x1f function 0x06: vendor 0x8086 device 0x3b32
Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem

pci bus 0x0002 cardnum 0x00 function 0x00: vendor 0x14e4 device 0x4727
Broadcom Corporation Device unknown

pci bus 0x0003 cardnum 0x00 function 0x00: vendor 0x1969 device 0x2060
Atheros Communications AR8152 v1.1 Fast Ethernet
root@swiftlet:~#
root@swiftlet:~# dladm show-phys
root@swiftlet:~#

No output from "dladm show-phys". I noticed also that there could be a problem with OI not recognising Atheros.

#3

Updated by Milan Jurik over 7 years ago

pci bus 0x0002 cardnum 0x00 function 0x00: vendor 0x14e4 device 0x4727
Broadcom Corporation Device unknown

It is Broadcom BCM4313 and I think Illumos/Openindiana has no support for this WiFi chip at all. It could be possible to use it through ndiswrapper probably.

As for not recognized Atheros ethernet card, I would recommend to fill separate issue (and yes, there is missing driver also, maybe atge driver could be improved to support it).

#4

Updated by daniel kho over 7 years ago

Hi, I recently found out BCM4313 was listed in upstream from Oracle:
https://hg.openindiana.org/upstream/oracle/userland-gate/rev/e737075f09d1

Does this mean OI could support this too?

#5

Updated by Milan Jurik over 7 years ago

That is not list of supported HW but overview of all known HW in one public cross-platform data file. I am sorry it has no connection with actually supported HW.

#6

Updated by Ken Mays over 7 years ago

  • Category set to Drivers
  • Status changed from Feedback to Rejected

OI does not provide new Wifi driver support directly. Please request this through Illumos project.

#7

Updated by Milan Jurik over 7 years ago

  • Status changed from Rejected to Feedback

As the issue was reported on OI and Illumos and OI share the same bug tracking system, the report cannot be rejected (it is valid RFE) but has to be moved by somebody with enough power to Illumos project.

#8

Updated by Ken Mays over 7 years ago

  • Due date set to 2012-03-30
  • Status changed from Feedback to Resolved
  • Assignee set to Ken Mays
  • Priority changed from Normal to Low
  • Target version set to oi_151_stable
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h
  • Tags changed from needs-triage to broadcom

Milan - The Illumos team is already looking into Broadcom support of new hardware, but users can use the workaround below for a QUICKER resolution.

Daniel - My actual workaround and resolution: Replace Broadcom Wifi adapter with the compatible Wifi USB adapter (i.e. Linksys WUSBF54G, Ambicom WL54-USB, A-LINK WL54USB). These devices are still available on the Internet and the drivers are already included in the OI distro.

#9

Updated by Milan Jurik over 7 years ago

  • Status changed from Resolved to Feedback
  • Assignee deleted (Ken Mays)
  • Target version deleted (oi_151_stable)
  • % Done changed from 100 to 0

Ken, please, do not close issues if they are not solved. Either close this as duplicate of some other issue or deliver fix.

Workaround based on USB wifi adapter is good workaround but it is not the fix of the problem.

This issue exists and should be solved.

#10

Updated by Ken Mays over 7 years ago

Milan - The closure of this ticket was based due to near duplicate of #564 which was requested over a year ago:
See: https://www.illumos.org/issues/564 (which explains more)
and https://www.illumos.org/issues/182 (duplicate)

In which, I was going to refer the user over to the possible fix using NDIS and Windows drivers (+firmware availability): http://learningsolaris.com/archives/2009/03/10/opensolaris-wifi-broadcom-bcm4312-on-dell-vostro-1710/

Basically we already have a possible solution for this issue, and I've created a workaround in case that didn't work. We can leave the ticket open for confirmation.

#11

Updated by daniel kho over 7 years ago

Hi Ken, the NDIS driver as referenced by the learningsolaris.com link has been removed by Oracle. This link is now broken:
http://hub.opensolaris.org/bin/download/Community+Group+laptop/ndis/ndis-1.2.1.tar.gz

I guess I will have to purchase either one of those proposed wireless cards. By the way, do you have an idea as to when OI will provide this fix?

#12

Updated by Enrico Papi over 7 years ago

hi, i think Oracle removed the entire laptop community webpage two weeks ago

#13

Updated by Milan Jurik over 7 years ago

Shame on them. Here is some version I had archived - https://www.opensolaris.cz/sites/opensolaris.cz/files/ndis-1.2.1.tar.gz

#14

Updated by Ken Mays over 6 years ago

  • Assignee set to OI illumos
#15

Updated by Ken Mays over 6 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (OI illumos)
  • % Done changed from 0 to 100

Workaround was to use ndis which is now unsupported, so no other resolution can be provided as this driver is not supported directly through Illumos (nor Broadcom except for legacy). Closing ticket. As mentioned, use a supported HW solution if necessary.

#16

Updated by Jim Klimov over 6 years ago

Regarding an ndis wrapped solution with WEP support, now there is one, see bug #3367. A natively illumos driver (something open-sourced and integrated with the OS) is still missing.
In particular, I have the same card and it works now: pciex14e4,4727.

Also available in: Atom PDF