Project

General

Profile

Bug #2161

rebuild illumos-gate for OI after openssl upgrades

Added by Bayard Bell almost 8 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Security
Target version:
-
Start date:
2012-02-21
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Components in illumos-gate depend on libcrypto in userland. If openssl is upgraded, illumos-gate needs to be rebuilt against the updated openssl headers. We will need to do this as part of the CVE process. Otherwise bad things will happen.

History

#1

Updated by Jon Tibble almost 8 years ago

Does this affect 0.9.8 bumps as well or just bumps to v1 with the corresponding changes in lib numbers? I was planning to take stable as far as 0.9.8t (or later as released) but not to v1. The v1 game is for you all to play in experimental.

#2

Updated by Jon Tibble over 7 years ago

Just to keep track... m2crypto no longer needs bumping to be able to cope with openssl v1 after it got bumped in the pkg bump for prestable2

#3

Updated by Ken Mays almost 7 years ago

  • Assignee set to OI PKG
#4

Updated by Ken Mays almost 6 years ago

  • Assignee changed from OI PKG to OI illumos
#5

Updated by Ken Mays over 5 years ago

  • Status changed from New to Closed
  • Target version deleted (oi_151_stable)
  • % Done changed from 0 to 100

Resolved.

Also available in: Atom PDF