Bug #2164

Incomplete dependencies for ffmpeg@0.9.1-0.151.1

Added by Andrew Chace about 2 years ago. Updated almost 2 years ago.

Status:Rejected Start date:2012-02-22
Priority:Normal Due date:
Assignee:Alex Viskovatoff % Done:

10%

Category:-
Target version:-
Difficulty:Medium Tags:needs-triage

Description

After installing "" on "oi_151a", I received the following error message when I attempted to run 'ffmpeg':

[ajchace@opensolaris] ffmpeg -v
ld.so.1: ffmpeg: fatal: libass.so.4: open failed: No such file or directory
ld.so.1: ffmpeg: fatal: relocation error: file /usr/lib/libavfilter.so.2: symbol ass_set_frame_size: referenced symbol not found
ld.so.1: ffmpeg: fatal: relocation error: file /usr/lib/libavdevice.so.53: symbol avfilter_graph_free: referenced symbol not found
ld.so.1: ffmpeg: fatal: relocation error: file /usr/bin/ffmpeg: symbol avdevice_register_all: referenced symbol not found
Killed

Installing "pkg:/library/video/" resolved this problem:

[ajchace@opensolaris] pfexec pkg install pkg:/library/video/libass@0.9.13-0.151.1
               Packages to install:     1
           Create boot environment:    No
DOWNLOAD                                  PKGS       FILES    XFER (MB)
Completed                                  1/1         5/5      0.1/0.1

PHASE                                        ACTIONS
Install Phase                                  24/24 

PHASE                                          ITEMS
Package State Update Phase                       1/1 
Image State Update Phase                         2/2 

PHASE                                          ITEMS
Reading Existing Index                           8/8 
Indexing Packages                                1/1

[ajchace@opensolaris] ffmpeg -v
ld.so.1: ffmpeg: fatal: libopenal.so.1: open failed: No such file or directory
ld.so.1: ffmpeg: fatal: relocation error: file /usr/lib/libavdevice.so.53: symbol alcCaptureStop: referenced symbol not found
ld.so.1: ffmpeg: fatal: relocation error: file /usr/bin/ffmpeg: symbol avdevice_register_all: referenced symbol not found
Killed

Installing "pkg:/library/audio/" resolved this problem:

[ajchace@opensolaris] pfexec pkg install pkg:/library/audio/openal@1.13-0.151.1
               Packages to install:     2
           Create boot environment:    No
DOWNLOAD                                  PKGS       FILES    XFER (MB)
Completed                                  2/2       12/12      0.3/0.3

PHASE                                        ACTIONS
Install Phase                                  52/52 

PHASE                                          ITEMS
Package State Update Phase                       2/2 
Image State Update Phase                         2/2 

PHASE                                          ITEMS
Reading Existing Index                           8/8 
Indexing Packages                                2/2
Indexing Packages                                2/2
Optimizing Index...

PHASE                                          ITEMS
Indexing Packages                          1041/1041 
[ajchace@opensolaris] ffmpeg -v
ffmpeg version 0.9.1, Copyright (c) 2000-2012 the FFmpeg developers
  built on Jan 13 2012 20:02:19 with gcc 4.6.2
  configuration: --prefix=/usr --bindir=/usr/bin --libdir=/usr/lib --shlibdir=/usr/lib --mandir=/usr/share/man --cc=gcc --cpu=pentiumpro --enable-runtime-cpudetect --enable-mmx --enable-mmx2 --enable-sse --enable-ssse3 --enable-amd3dnow --enable-amd3dnowext --disable-debug --enable-nonfree --enable-gpl --enable-runtime-cpudetect --enable-postproc --enable-avfilter --enable-swscale --enable-libgsm --enable-libxvid --enable-libx264 --enable-libfaac --enable-libtheora --enable-libmp3lame --enable-libvorbis --enable-libvpx --enable-x11grab --enable-libspeex --enable-pthreads --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3 --disable-static --disable-mlib --enable-libschroedinger --enable-libopenjpeg --enable-librtmp --enable-vdpau --enable-libass --enable-openssl --enable-openal --enable-shared
  libavutil    51. 32. 0 / 51. 32. 0
  libavcodec   53. 42. 4 / 53. 42. 4
  libavformat  53. 24. 2 / 53. 24. 2
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 53. 0 /  2. 53. 0
  libswscale    2.  1. 0 /  2.  1. 0
  libpostproc  51.  2. 0 / 51.  2. 0
Missing argument for option 'v'

History

Updated by Milan Jurik about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Alex Viskovatoff
  • % Done changed from 0 to 10

SFElibass and SFEopenal should be added to Requires in SFEffmpeg.

Updated by Garrett D'Amore about 2 years ago

  • Project changed from illumos gate to illumos-userland

Updated by Alasdair Lumsden almost 2 years ago

  • Status changed from In Progress to Rejected

This needs to go in SFE, not illumos-userland.

Also available in: Atom PDF