Bug #220

time slider not working

Added by paolo marcheschi over 3 years ago. Updated almost 3 years ago.

Status:Resolved Start date:2010-09-17
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Desktop (JDS)
Target version:oi_151
Difficulty:Medium Tags:needs-triage

Description

Hi
running time slider I get :
paolo@opensolaris:/usr/bin$ time-slider-setup
Traceback (most recent call last):
File "/usr/bin/time-slider-setup", line 12, in <module>
main(abspath(file))
File "/usr/bin/../share/time-slider/lib/time_slider/setupgui.py", line 1299, in main
manager = SetupManager(argv)
File "/usr/bin/../share/time-slider/lib/time_slider/setupgui.py", line 184, in init
self._fsDevices[os.stat(fsmountpoint).st_dev] = fs
OSError: [Errno 2] No such file or directory: '/tmp/tmpRoKO4s'
paolo@opensolaris:/usr/bin$ uname -a
SunOS opensolaris 5.11 oi_147 i86pc i386 i86pc Solaris

if I try to remove it in order to reinstall from the package manager it crashes with this error:
Error details:
Traceback (most recent call last):
File "/usr/lib/python2.6/vendor-packages/pkg/gui/globalexceptionhandler.py", line 71, in run_with_except_hook
run_old(*rweh_args, **rweh_kwargs)
File "/usr/lib/python2.6/threading.py", line 477, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/lib/python2.6/vendor-packages/pkg/gui/installupdate.py", line 645, in _proceed_with_stages_thread_ex
self.
_proceed_with_stages_thread_ex_with_lock(continue_operation)
File "/usr/lib/python2.6/vendor-packages/pkg/gui/installupdate.py", line 731, in __proceed_with_stages_thread_ex_with_lock
"depend on it:\n") % nlpe0.get_name()
IndexError: tuple index out of range

List of configured publishers:
P O openindiana.org (http://pkg.corp.it/oi_dev/)
P O openindiana.org (http://pkg.openindiana.org/dev/)
E O contrib (http://pkg.opensolaris.org/contrib/)
E O contrib.opensolaris.org (http://pkg.opensolaris.org/contrib/)
E O extra (https://pkg.sun.com/opensolaris/extra/)
E O opensolaris.org (http://pkg.openindiana.org/legacy/)
E M opensolaris.org (http://pkg.mirror.garr.it:8080/)

pkg version:
552262a56a9a

Paolo

History

Updated by Albert Lee over 3 years ago

  • Status changed from New to Feedback

Unable to reproduce this, can you test oi_148?

Updated by Fred Kimball over 3 years ago

Hi, I first noticed the time-slider not working message when shutting down after installing oi_147. It's still present in oi_148. Using an HP with amd_64.

$ uname -a
SunOS opensolaris 5.11 oi_148 i86pc i386 i86pc

$ svcs -xv
svc:/application/time-slider:default (GNOME Desktop Snapshot Management Service)
State: maintenance since December 20, 2010 07:21:50 PM EST
Reason: Restarting too quickly.
See: http://sun.com/msg/SMF-8000-L5
See: man -M /usr/share/man -s 1M zfs
See: /var/svc/log/application-time-slider:default.log
Impact: 5 dependent services are not running:
svc:/system/filesystem/zfs/auto-snapshot:daily
svc:/system/filesystem/zfs/auto-snapshot:frequent
svc:/system/filesystem/zfs/auto-snapshot:hourly
svc:/system/filesystem/zfs/auto-snapshot:monthly
svc:/system/filesystem/zfs/auto-snapshot:weekly

Last couple of entries into:
/var/svc/log/application-time-slider:default.log
Error details:
--------BEGIN ERROR MESSAGE--------
['/usr/bin/pfexec', '/usr/sbin/zfs', 'destroy', '-d', 'rpool@zfs-auto-snap_frequent-2010-09-26-15h45'] failed with exit code 1
cannot destroy 'rpool@zfs-auto-snap_frequent-2010-09-26-15h45': unsupported version

--------END ERROR MESSAGE--------
Snapshot monitor thread exited.
[ Dec 20 19:06:49 Stopping because all processes in service exited. ]
[ Dec 20 19:06:50 Executing stop method (:kill). ]
[ Dec 20 19:06:50 Executing start method ("/lib/svc/method/time-slider start"). ]
[ Dec 20 19:07:06 Method "start" exited with status 0. ]
Failed to destroy snapshot: rpool@zfs-auto-snap_frequent-2010-09-26-15h45
Can not determine used size of: rpool@zfs-auto-snap_frequent-2010-09-26-15h45
Error listing datasets during removal of expired snapshots
Caught RuntimeError exception in snapshot manager thread
Error details:
--------BEGIN ERROR MESSAGE--------
['/usr/bin/pfexec', '/usr/sbin/zfs', 'destroy', '-d', 'rpool@zfs-auto-snap_frequent-2010-09-26-15h45'] failed with exit code 1
cannot destroy 'rpool@zfs-auto-snap_frequent-2010-09-26-15h45': unsupported version

--------END ERROR MESSAGE--------
Snapshot monitor thread exited.
[ Dec 20 19:21:50 Stopping because all processes in service exited. ]
[ Dec 20 19:21:50 Executing stop method (:kill). ]
[ Dec 20 19:21:50 Restarting too quickly, changing state to maintenance. ]

Updated by Maxim Kondratovich over 3 years ago

It´s upgrade bug. If u delete database of humster it starts successfully.

Updated by Maxim Kondratovich over 3 years ago

Maxim Kondratovich wrote:

It´s upgrade bug. If u delete database of humster it starts successfully.

It's wrong comment! Sorry guys, please delete it if it is possible.

Updated by Matt Wilby over 3 years ago

  • Category set to Desktop (JDS)
  • Assignee set to Matt Wilby

Fresh install of oi_148. Works as expected, can't reproduce. Have you tried this is a fresh install?

Updated by Chris Jordan about 3 years ago

Regarding the comment above by Fred Kimball about the error message:

cannot destroy 'rpool@zfs-auto-snap_frequent-2010-09-26-15h45': unsupported version

That is due to the version of the zfs pool being less than 18. See https://defect.opensolaris.org/bz/show_bug.cgi?format=multiple&id=16361. Running pfexec zpool upgrade -a should upgrade all your pools and fix that error. However that doesn't, in my case, fix the originally reported problem where time-slider-setup fails to run on build 147. I'm going to upgrade to build 148 and see if that helps any.

Updated by Chris Jordan about 3 years ago

I had the same error as the original submitter, and upgrading from build 147 to build 148 fixed the problem for me. The time-slider-setup program runs correctly without error now.

Updated by paolo marcheschi about 3 years ago

Chris Jordan wrote:

I had the same error as the original submitter, and upgrading from build 147 to build 148 fixed the problem for me. The time-slider-setup program runs correctly without error now.

Yes , After the Upgrade at the latest version work for me as well.

Thank you

Paolo

Updated by Albert Lee about 3 years ago

  • Assignee deleted (Matt Wilby)
  • Target version set to oi_151

https://defect.opensolaris.org/bz/show_bug.cgi?id=16441 is the upstream bug for the /tmp error.

Updated by Fred Kimball about 3 years ago

After my original post, I manually deleted the problem snapshot which solved the problem. I have since updated zpool and zfs.

Updated by Julian Wiesener almost 3 years ago

  • Status changed from Feedback to Resolved
  • Difficulty set to Medium
  • Tags set to needs-triage

Original problem already fixed in 148, manual steps need to be done as possible results of an upgrade from earlier version.

Also available in: Atom PDF