Project

General

Profile

Actions

Bug #2248

open

assertion failed: ilu->ilu_ntasks_min_free <= ilu->ilu_ntasks_free

Added by Will Murnane over 9 years ago. Updated over 9 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
comstar - iSCSI/FC/SAS target
Start date:
2012-03-06
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

My system at home panicked overnight:

$ fmdump -Vp -u bbe929b5-c7b1-c366-d952-ca71caa76cfd
TIME                           UUID                                 SUNW-MSG-ID
Mar 05 2012 19:02:53.516595000 bbe929b5-c7b1-c366-d952-ca71caa76cfd SUNOS-8000-KL

  TIME                 CLASS                                 ENA
  Mar 05 19:02:48.8222 ireport.os.sunos.panic.dump_pending_on_device 0x0000000000000000

nvlist version: 0
        version = 0x0
        class = list.suspect
        uuid = bbe929b5-c7b1-c366-d952-ca71caa76cfd
        code = SUNOS-8000-KL
        diag-time = 1330992173 449387
        de = fmd:///module/software-diagnosis
        fault-list-sz = 0x1
        fault-list = (array of embedded nvlists)
        (start fault-list[0])
        nvlist version: 0
                version = 0x0
                class = defect.sunos.kernel.panic
                certainty = 0x64
                asru = sw:///:path=/var/crash/openindiana/.bbe929b5-c7b1-c366-d952-ca71caa76cfd
                resource = sw:///:path=/var/crash/openindiana/.bbe929b5-c7b1-c366-d952-ca71caa76cfd
                savecore-succcess = 0
                os-instance-uuid = bbe929b5-c7b1-c366-d952-ca71caa76cfd
                panicstr = assertion failed: ilu->ilu_ntasks_min_free <= ilu->ilu_ntasks_free, file: ../../common/io/comstar/stmf/stmf.c, line: 4587
                panicstack = genunix:process_type+18a18b () | stmf:stmf_task_lu_check_freelist+13e () | stmf:stmf_check_freetask+7f () | stmf:stmf_svc_timeout+24e () | stmf:stmf_svc+af () | genunix:taskq_thread+32f () | unix:thread_start+8 () |
                crashtime = 1330992076
                panic-time = March  5, 2012 07:01:16 PM EST EST
        (end fault-list[0])

        fault-status = 0x1
        severity = Major
        __ttl = 0x1
        __tod = 0x4f55542d 0x1eca9d38

It's running as a VMware ESXi guest, and serving iSCSI to another guest on the same machine. This configuration has worked just fine for a few months. I have ECC memory installed, and I don't see any errors related to it in the host logs, so I don't think it's just a bitflip.

Here are the results from savecore:

$ sudo savecore -vf vmdump.0
savecore: incomplete dump on dump device
savecore: System dump time: Mon Mar  5 19:01:16 2012

savecore: saving system crash dump in /var/crash/openindiana/{unix,vmcore}.0
Constructing namelist /var/crash/openindiana/unix.0
Constructing corefile /var/crash/openindiana/vmcore.0
pfn 4065792 not found for as=fffffffffbc3f160, va=ffffff0000000000
pfn 4065793 not found for as=fffffffffbc3f160, va=ffffff0000001000
pfn 4065794 not found for as=fffffffffbc3f160, va=ffffff0000002000
pfn 4065795 not found for as=fffffffffbc3f160, va=ffffff0000003000
pfn 4065796 not found for as=fffffffffbc3f160, va=ffffff0000004000
pfn 4065797 not found for as=fffffffffbc3f160, va=ffffff0000005000
pfn 4065798 not found for as=fffffffffbc3f160, va=ffffff0000006000
pfn 4065799 not found for as=fffffffffbc3f160, va=ffffff0000007000
pfn 4065800 not found for as=fffffffffbc3f160, va=ffffff0000008000
pfn 4065801 not found for as=fffffffffbc3f160, va=ffffff0000009000
 2:13  99% donesavecore: stream tag 3247 not in range 1..5
savecore: bad summary magic dd2b44d0

That doesn't look particularly happy. This is very likely because the system has 16GB of memory, and only 16GB of root filesystem, leaving not enough room to write a full dump. I'll work on reconfiguring things to leave enough room for a complete dump in case this should recur.

The resultant core files are available at http://twoevils.net/.cores/ (total size about 2GB). The mdb command listed on "how to report bugs" doesn't work against them, but I'd bet someone who knows what they're doing can still get some use from them.

Actions

Also available in: Atom PDF