Project

General

Profile

Bug #235

SMF Service reports zfssnap-roleadd in maintenance state

Added by Robin k about 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
Start date:
2010-09-20
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

After upgrading from the lastest OpenSolaris dev build, on first boot the SMF Services applet reports 1 unhealthy instance.

svs:/system/filesystem/zfssnap-roleadd:default in "maintenance state"

Is also reported at https://bugs.launchpad.net/openindiana/+bug/641477

Additional info
rok@raser:~$ zpool list
NAME SIZE ALLOC FREE CAP DEDUP HEALTH ALTROOT
rpool 696G 92.7G 603G 13% 1.00x ONLINE -

rok@raser:~$ zpool get all rpool
NAME PROPERTY VALUE SOURCE
rpool size 696G -
rpool capacity 13% -
rpool altroot - default
rpool health ONLINE -
rpool guid 16765051844372659720 local
rpool version 22 local
rpool bootfs rpool/ROOT/opensolaris-1 local
rpool delegation on default
rpool autoreplace off default
rpool cachefile - default
rpool failmode wait default
rpool listsnapshots off default
rpool autoexpand off default
rpool dedupditto 0 default
rpool dedupratio 1.00x -
rpool free 603G -
rpool allocated 92.7G -
rpool readonly off -


Files

Screenshot-1.png (24.9 KB) Screenshot-1.png screenshot Robin k, 2010-09-20 02:53 AM

Related issues

Related to illumos gate - Bug #1564: SMF Service reports zfssnap-roleadd in maintenance stateRejected2010-09-20

Actions
Related to illumos gate - Bug #1565: svccfg cleanup needs to suck it up and finish the jobClosed2011-09-25

Actions
Related to OpenIndiana Distribution - Bug #1179: ZFS time-slider and auto-snapshots not working due to missing zfssnap-roleadd SMF serviceClosed2011-07-04

Actions

History

#2

Updated by Guy Woolley about 9 years ago

This is also noted at

https://defect.opensolaris.org/bz/show_bug.cgi?id=16994

I have the same problem, noted here in #bug 207

#3

Updated by Albert Lee about 9 years ago

  • Category set to OS/Net (Kernel and Userland)
  • Target version set to oi_148

The root cause for this bug is http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6983942 (although the more important bug is in svccfg cleanup's error handling). I will try to address these issues for oi_148.

#4

Updated by Albert Lee about 9 years ago

  • Assignee set to Albert Lee
#5

Updated by Albert Lee about 9 years ago

The fix will be in 148.

#6

Updated by Albert Lee about 9 years ago

  • Status changed from New to In Progress

Technically there are two separate bugs here, this fixes the underlying bug (early termination of svccfg cleanup):
http://pkgdev.openindiana.org/hg/mq_onnv-gate/file/58e0a79afe38/oi-issue-235-svccfg_cleanup_fail

And this is the fix for 6983942:
http://pkgdev.openindiana.org/hg/mq_onnv-gate/file/58e0a79afe38/oi-issue-6983942-svccfg_man_sections

#7

Updated by Albert Lee almost 9 years ago

  • Status changed from In Progress to Resolved

Fixed in oi_148. illumos will have slightly different property group name (no underscores) to match snv_151 behaviour.

Also available in: Atom PDF