Project

General

Profile

Actions

Bug #240

closed

CUPS hpcac filter missing from hplip

Added by Hillel Lubman over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
OI-Userland
Target version:
Start date:
2010-09-20
Due date:
2011-09-14
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Bite-size
Tags:
CUPS

Description

When using CUPS printing manager, adding a network HP Color LaserJet 3800 printer produces an error:

"Printer [name] requires the 'hpcac' program, but it is not currently installed.
Please install it before using the printer."

The subsequent printing fails as well because of this. The actual hpcac is a script which is available in http://src.opensolaris.org/source/xref/sfw/usr/src/cmd/hplip/hplip-3.9.8/prnt/filters/hpcac

If manually copied to /usr/lib/cups/filter with 0555 permissions - it solves the problem. The problem is caused by hplip package omitting hpcac filter for some reason.

Actions #1

Updated by Albert Lee over 10 years ago

  • Assignee set to Sevan Janiyan

Sevan, would you mind taking this? Seems like an trivial change with no impact to people who don't use the filter.

Actions #2

Updated by Albert Lee over 10 years ago

  • Assignee deleted (Sevan Janiyan)
  • Priority changed from Normal to Low
Actions #3

Updated by Chris Jordan almost 10 years ago

  • Assignee set to OI SFW
  • Difficulty set to Medium
  • Tags set to CUPS
Actions #4

Updated by Ken Mays over 9 years ago

  • Status changed from New to Feedback
  • Target version set to oi_151_stable
  • % Done changed from 0 to 100
Actions #5

Updated by Ken Mays over 9 years ago

  • Due date set to 2011-09-14
  • Status changed from Feedback to New
  • Assignee changed from OI SFW to OI Userland
  • % Done changed from 100 to 0
  • Estimated time set to 8.00 h
  • Difficulty changed from Medium to Bite-size
Actions #6

Updated by Ken Mays over 9 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Estimated time changed from 8.00 h to 1.00 h

This is marked under oi_151a known issue. I was told adding hpcac to the packaging of CUPS is NOT preferred due to its perl dependency and not part of the true package. Also, it was removed as 'unused' by the hplip developer(s). Closing ticket based on request.

Actions

Also available in: Atom PDF