Bug #240

CUPS hpcac filter missing from hplip

Added by Hillel Lubman almost 5 years ago. Updated almost 4 years ago.

Status:ClosedStart date:2010-09-20
Priority:LowDue date:2011-09-14
Assignee:OI Userland% Done:

100%

Category:SFW (Solaris Freeware)Estimated time:1.00 hour
Target version:oi_151_stable
Difficulty:Bite-size Tags:CUPS

Description

When using CUPS printing manager, adding a network HP Color LaserJet 3800 printer produces an error:

"Printer [name] requires the 'hpcac' program, but it is not currently installed.
Please install it before using the printer."

The subsequent printing fails as well because of this. The actual hpcac is a script which is available in http://src.opensolaris.org/source/xref/sfw/usr/src/cmd/hplip/hplip-3.9.8/prnt/filters/hpcac

If manually copied to /usr/lib/cups/filter with 0555 permissions - it solves the problem. The problem is caused by hplip package omitting hpcac filter for some reason.

History

#1 Updated by Albert Lee almost 5 years ago

  • Assignee set to Sevan Janiyan

Sevan, would you mind taking this? Seems like an trivial change with no impact to people who don't use the filter.

#2 Updated by Albert Lee over 4 years ago

  • Assignee deleted (Sevan Janiyan)
  • Priority changed from Normal to Low

#3 Updated by Chris Jordan about 4 years ago

  • Assignee set to OI SFW
  • Difficulty set to Medium
  • Tags set to CUPS

#4 Updated by Ken Mays about 4 years ago

  • % Done changed from 0 to 100
  • Target version set to oi_151_stable
  • Status changed from New to Feedback

#5 Updated by Ken Mays almost 4 years ago

  • Due date set to 2011-09-14
  • Assignee changed from OI SFW to OI Userland
  • Estimated time set to 8.00
  • Difficulty changed from Medium to Bite-size
  • Status changed from Feedback to New
  • % Done changed from 100 to 0

#6 Updated by Ken Mays almost 4 years ago

  • Status changed from New to Closed
  • Estimated time changed from 8.00 to 1.00
  • % Done changed from 0 to 100

This is marked under oi_151a known issue. I was told adding hpcac to the packaging of CUPS is NOT preferred due to its perl dependency and not part of the true package. Also, it was removed as 'unused' by the hplip developer(s). Closing ticket based on request.

Also available in: Atom