Project

General

Profile

Bug #2401

buffer free to wrong cache

Added by eric zhang over 8 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
-
Category:
-
Start date:
2012-03-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

We install the openindiana on raid0 SAS HDD, when we run our kernek program, the kernel crash, show "kernel memory allocator : buffer freed to wrong cache"
"buffer was allocated from kmem_alloc_160."
"caller attempting free to kmem_alloc_48"
But when we install os to sata disk, no crash occur. And we have check our program, it alloc and free memory correctly.


Files

crash.jpg (559 KB) crash.jpg eric zhang, 2012-03-13 06:33 AM

History

#1

Updated by eric zhang over 8 years ago

sorry , my os infor.
uname -a
SunOS vs1 5.11 oi_151a2 i86pc i386 i86pc Solaris

#2

Updated by Milan Jurik over 8 years ago

  • Status changed from New to Feedback

What is your "kernel program" (is it device driver?) doing?

Which SAS adapter do you use?

Is the crash reproducible? If yes, can you run savecore program to take crashdump file for examination?

#3

Updated by eric zhang over 8 years ago

MJ,

thanks.

kernel program not device driver, just one cache module.
SAS adapter: LSI MegaRAID SAS 9240-8i 2.120.54-1235

we open savecore with dumpadm -y, but nothing in save directory.

#4

Updated by Milan Jurik over 8 years ago

Which driver do you use for that MegaRAID? imr_sas from LSI?

From the screenshot you provided I see that savecore was stored. So on that system after crashdump, run just:

savecore

and than look at content of /var/crash/

#5

Updated by eric zhang over 8 years ago

the driver from LSI, version. 3.03_2008_Solaris

from the screenshot, we saw it should be saved in /var/crash/vs2/, but after reboot, no file in the forder.

#6

Updated by Milan Jurik over 8 years ago

Even if you run "savecore" command manually, no data are stored to /var/crash/ ?

#7

Updated by jeff chen over 8 years ago

eric zhang wrote:

the driver from LSI, version. 3.03_2008_Solaris

from the screenshot, we saw it should be saved in /var/crash/vs2/, but after reboot, no file in the forder.

Maybe your swap file/device size(capacity) is not enough to save the memory dump.

#8

Updated by Albert Lee over 8 years ago

This is a known issue in imr_sas, which uses a struct scsi_inquiry size from Solaris 10. Nexenta has reported this issue to LSI. The open mr_sas driver should support your hardware, just use that.

#9

Updated by eric zhang over 8 years ago

OK, I will update the driver and have a check.

#10

Updated by eric zhang over 8 years ago

Albert Lee wrote:

This is a known issue in imr_sas, which uses a struct scsi_inquiry size from Solaris 10. Nexenta has reported this issue to LSI. The open mr_sas driver should support your hardware, just use that.

Albert,

My raid card is LSI MegaRAID SAS 9240-8i 2.120.54-1235,

Can i use the driver from http://www.lsi.com/support/products/Pages/MegaRAIDSAS9240-8i.aspx ???

Solaris x86 - 4.6 - 10M09
Driver Solaris x86 Driver
OS: Solaris 10 x86
Version: 3.03
Readme Link: readme Dec 17, 2010 0.51M

or

Solaris x86 - 4.6
Driver Solaris x86 Driver
OS: Solaris 10 x86
Version: 3.01
Readme Link: readme Jan 26, 2010 460.6K.

I have no idea about imr_sas or mr_sas..

thanks..

#11

Updated by David King over 8 years ago

Another data point. I also have this issue with my IBM M1015 (SAS2008) controller with the default (IR) firmware using the imr_sas driver. I am using the imr_sas driver because the oi_151a2 mr_sas driver does not detect my controller.

#12

Updated by Josef Sipek over 6 years ago

  • Status changed from Feedback to Rejected

This bug concerns a closed driver. Since (1) we can't debug it, and (2) we have an open source alternative, I'm rejecting this bug.

Also available in: Atom PDF