Project

General

Profile

Bug #2428

imagemagick missing directory

Added by Marion Hakanson over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
-
Start date:
2012-03-19
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
imagemagic

Description

I ran into the following error, running oi151a2, ImageMagick installed from the default repository.

$ convert 'vid:*.BMP' directory.miff
convert: unable to read font `/usr/share/ghostscript/fontsx/n019003l.pfb' @ error/annotate.c/RenderFreetype/1120.
convert: memory allocation failed `/var/tmp/magick-YuZBaiaB-00000001' @ error/png.c/ReadOnePNGImage/2122.
convert: corrupt image `/var/tmp/magick-YuZBaiaB-00000001' @ error/png.c/ReadPNGImage/3667.
convert: Postscript delegate failed `/var/tmp/magick-YWWBaiaB': No such file or directory @ error/ps.c/ReadPSImage/805.
convert: unable to lock semaphore `Deadlock situation detected/avoided' @ fatal/semaphore.c/LockSemaphoreInfo/273.
$ ls -l /usr/share/ghostscript/fontsx
/usr/share/ghostscript/fontsx: No such file or directory
$ 

I found that the following fixes the error:

# cd /usr/share/ghostscript/
# ln -s fonts fontsx
#1

Updated by Ryo Murakawa over 8 years ago

  • Assignee set to OI PKG
  • Tags changed from needs-triage to imagemagic
#2

Updated by Ken Mays almost 8 years ago

  • Assignee changed from OI PKG to Adam ┼átevko
#3

Updated by Ken Mays over 7 years ago

  • Status changed from New to Feedback
  • Assignee changed from Adam ┼átevko to OI Userland
#4

Updated by Ken Mays over 7 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Tested by Alexander Pyhalov:
"Even with old package I can't reproduce this:

$ convert 'vid:*.bmp' directory.miff
convert: unable to read font `/usr/share/ghostscript/fonts/n019003l.pfb'.

$ convert -version
Version: ImageMagick 6.3.4 03/04/13 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2007 ImageMagick Studio LLC"

But this is easily fixed now by adding this package in /hipster:
,5.11-0.151.1.8.1:20130627T100148Z
usr/share/ghostscript/fonts/n019003l.pfb

closing ticket.

Also available in: Atom PDF