Bug #2430

panic: BAD TRAP under heavy load with mpt_sas

Added by Rich Ercolani about 2 years ago. Updated almost 2 years ago.

Status:New Start date:2012-03-20
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-
Difficulty:Medium Tags:needs-triage

Description

uname -a:

SunOS nosuch3 5.11 oi_151a2 i86pc i386 i86pc Solaris

PowerEdge R815, with 2 LSI 9201-16e cards running P12 firmware/BIOS in IT mode. Under what appears to have been normal load (no new drives, no new commands, the command that presumably caused the hang had worked 2 minutes prior and works now if run), machine paniced, dumped, rebooted.

Output from fmdump is attached; I have a vmdump, but...

  1. ls alh /var/crash/nosuch3/vmdump.0
    -rw-r--r-
    1 root root 16G Mar 19 19:57 /var/crash/nosuch3/vmdump.0

809b1ea5-b0cd-caba-ba87-d4312d4d7b5d.log.txt - fmdump -Vp -u 809b1ea5-b0cd-caba-ba87-d4312d4d7b5d (1.3 kB) Rich Ercolani, 03/20/2012 01:01 am

History

Updated by Alasdair Lumsden about 2 years ago

Hi Rich,

Can you provide a bit more information - is this a fresh install or has this machine been running fine until you updated OI?

Thanks,

Alasdair

Updated by Rich Ercolani about 2 years ago

It's not clear to me what triggered it - this machine has never been below oi_151, but it also hasn't had this recur since I reported the bug, nor had it ever happened prior, nor has it happened on other extremely similar machines.

Updated by Milan Jurik about 2 years ago

The size of crashdump is really big - did you enable taking userspace pages also?

If I provide some space for uploading crashdump, can you send upload it to me?

Updated by Rich Ercolani about 2 years ago

I mean, I can host the crashdump easily, I just wanted to explain why I didn't initially post it.

http://skysrv.pha.jhu.edu/~rercola/vmdump.0.xz

Updated by Rich Ercolani almost 2 years ago

Neat, it did it again. Same system.

Updated by Piotr Jasiukajtis almost 2 years ago

  • Project changed from OpenIndiana Distribution to illumos gate

Also available in: Atom PDF