Project

General

Profile

Actions

Bug #2448

closed

mpt_sas substract int32_t from long (64Bit)

Added by Peer Dampmann over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
driver - device drivers
Start date:
2012-03-23
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Several occurences where numeric datatypes of different size are substracted from each other

for example:

int32_t-long

static clock_t mptsas_scsi_watchdog_tick; (type long -> sizeof(long) 8 on 64Bit)
m_timeout int32_t

http://src.illumos.org/source/xref/illumos-gate/usr/src/uts/common/io/scsi/adapters/mpt_sas/mptsas.c#10051


Related issues

Is duplicate of illumos gate - Bug #2544: mpt_sas substract long from int32_t (64Bit)New2012-03-23

Actions
Actions #1

Updated by Garrett D'Amore over 10 years ago

  • Status changed from New to Closed

Duplicate bug id, closed are request of submitter.

Actions

Also available in: Atom PDF