Bug #245

can not lock screen if X screen saver is disabled

Added by n2deep n2deep over 3 years ago. Updated over 2 years ago.

Status:Closed Start date:2010-09-22
Priority:Low Due date:2011-12-31
Assignee:OI JDS % Done:

100%

Category:Desktop (JDS)
Target version:oi_151_stable Estimated time:1.00 hour
Difficulty:Bite-size Tags:jds

Description

on OpenIndiana b147, if X screen saver has been disabled, you can not lock your screen anymore. Re-enable X screen saver, and now you can lock your screen. Screen saver should never be a requirement to lock your screen.

History

Updated by Alan Coopersmith over 3 years ago

I can't see how this is a bug. If you disable the daemon that handles screenlock in GNOME,
then GNOME can't lock the screen. Don't do that. If you want to disable screen saving,
disable that feature in the preferences dialog, don't kill the entire daemon just because it's
name doesn't reflect all the functionality it provides.

You can always install and run xlock if you want to manually lock the screen without having
xscreensaver at all, but that's not integrated into the GNOME desktop.

Updated by Albert Lee over 3 years ago

  • Priority changed from Normal to Low

(Finally confirmed now that oi_148 has working xscreensaver). There actually appears to be a bug with the "Disable Screen Saver" option in xscreensaver-demo. When selected, xscreensaver remains running but "System->Lock" and xscreensaver-command -lock have no effect; the latter outputs this lie:

xscreensaver-command: activating and locking.

Updated by Julian Wiesener about 3 years ago

  • Category changed from XNV (X Window System) to Desktop (JDS)
  • Assignee set to OI JDS

Updated by Ken Mays over 2 years ago

  • Due date set to 2011-12-31
  • Target version set to oi_151_stable
  • Estimated time set to 8.00
  • Difficulty set to Bite-size
  • Tags set to jds

Updated by Ken Mays over 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Estimated time changed from 8.00 to 1.00

Not a JDS bug as mentioned. You can use xlock or similar tools.

Also available in: Atom PDF