Project

General

Profile

Bug #257

Iftop does not work

Added by Hervé Riboulot over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
OI-Userland
Target version:
Start date:
2010-09-25
Due date:
2011-09-14
% Done:

100%

Estimated time:
8.00 h
Difficulty:
Medium
Tags:
needs-triage

Description

Both on svn_134 and oi_147, iftop does not work.

Starting iftop (from the openindiana.org repository) drives to the following messages:

Herve@OpenIndiana:/etc/dhcp# iftop -i ath0
IP address is: 192.168.2.3
Unsupported datalink type: 105
Please email , quoting the datalink type and what you were
trying to do at the time

History

#1

Updated by Jon Tibble over 8 years ago

Does this interface have an IPv6 address on it as well as that v4 address(as these aren't supported)?

#2

Updated by Hervé Riboulot over 8 years ago

Good guess. The interface has two addresses:

ath0: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
inet 192.168.2.3 netmask ffffff00 broadcast 192.168.2.255
ether 0:12:bf:27:1:37
lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
inet6 ::1/128
ath0: flags=20002004841<UP,RUNNING,MULTICAST,DHCP,IPv6> mtu 1500 index 2
inet6 fe80::212:bfff:fe27:137/10
ether 0:12:bf:27:1:37

#3

Updated by Matt Wilby over 8 years ago

  • Status changed from New to In Progress
  • Assignee set to Matt Wilby
  • Priority changed from Normal to Low

Following on from Jon's advice, your ath0 interface has both IPv6 and IPv4 addresses. If you disable IPv6 does it work?

Looking at the release notes for iftop (http://www.ex-parrot.com/pdw/iftop/cvs/iftop/ChangeLog) version 1.0 does appear to support IPv6. The version in IPS is 0.17 is quite old (2006).

I'll explore the options of updating it.

#4

Updated by Matt Wilby over 8 years ago

I spoke too soon. The version quoted in the release notes refers to the pre-release. 0.17 is the latest stable.

#5

Updated by Ken Mays almost 8 years ago

  • Due date set to 2011-09-14
  • Category set to 10
  • Status changed from In Progress to Closed
  • Target version set to oi_151_stable
  • % Done changed from 0 to 100
  • Estimated time set to 8.00 h
  • Difficulty set to Medium
  • Tags set to needs-triage

iftop is supported in 1.0(pre) so this ticket can be closed as OI is dependent on upstream and a workaround exists for user to upgrade to 1.0.

Also available in: Atom PDF