Project

General

Profile

Bug #2645

poweroff/shutdown does not turn off the computer

Added by Dietmar Sovonja over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2012-04-20
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

When I shut down the computer with the poweroff or the shutdown command, the system is going down, but the computer does not turn off. I have to hold the power button to turn the computer off.

I installed the build 151a3 on 2 different computers, both with the same issue. (The 32-bit version on an Asus Eee PC 1000HE as well as the 64-bit version on a ASRock P5B-DE Mainboard with Intel dual-core D915.)

The computer turns off sometimes, but mostly not. On my desktop computer, after the message "syncing file systems... done", the system hangs. On the Asus Eee computer, the display turns off and the fan starts running with maximum speed, but the computer stays on.

Last messages:
poweroff: [ID 330035 auth.crit] initiated by didi on /dev/pts/1
syslogd: going down on signal 15
rpcbind: [ID 564983 daemon.error] rpcbind terminating on signal.
ntpd337: [ID 702911 daemon.notice] ntpd exiting on signal 15
genunix: [ID 672855 kern.notice] syncing file systems...
genunix: [ID 904073 kern.notice] done

I tried shutdown -y -i5 -g0, tried poweroff the computer from the console, without success.

On both computers I have the latest BIOS. I tried other OS (Debian, Haiku and Windows XP) and they all turn off the computer.

History

#1

Updated by Dieter Lange over 7 years ago

additional info: on Asus Sabertooth X58 (Corei7-950,24GB,GeForce G72,...OI_151a2) immediate reboot follows shutdown; hint: on same mobo+RAM (+other disks,DVD,graphics card) FreeBSD 9.0 release does switch the computer off.

#2

Updated by Udo Grabowski over 7 years ago

same problem on Dell Precision T3500, and a custom built with an ASUS P6T
motherboard. shutdown -g now always shuts down, using the Gnome
shutdown shuts down only in one of 30 attempts. Tried some workarounds
like switching off all processors except one or unload audio HD driver, but
nothing helps.

#3

Updated by andy page over 7 years ago

Did anyone figure out why some computers have this problem? It seems Open Indiana does everything so orderly including refusing to shutdown when asked as if this is against its very ethos. I therefore think this could be a psychological problem, someone should explain to it that turning off isn't a form of failure.

#4

Updated by Udo Grabowski over 7 years ago

This is a bit more serious, as I noticed that machines not going off will instead burn all CPUs on
full power indefinitely ! I don't know what can still run there since this is past the shutdown.
I suspect that this is present on all Intel X57/ICH10 mobos, since my Asus P6T as well as our
Dell T3500 Precision workstations show this behaviour. Something wrong with ACPI with these
Chipsets ?

#5

Updated by andy page about 7 years ago

I don't know what they've done but have just managed to upgrade to latest version of open indiana and reboot into new version! Shutdown and rebooted just to celebrate: seems to have been fixed =]

#6

Updated by Ken Mays almost 7 years ago

  • Status changed from New to Closed
  • Assignee changed from OI Userland to OI JDS
  • % Done changed from 0 to 100

Fixed based on user feedback.

Also available in: Atom PDF