Project

General

Profile

Feature #2673

parted should go

Added by Milan Jurik over 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cmd - userland programs
Start date:
2012-05-03
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:
Medium
Tags:
Gerrit CR:

Description

cmd/parted and lib/libparted are years old fork

It is not replacement for format/fdisk commands, it should go to userland gate.


Subtasks

Bug #2674: ntfsprogs should goClosedMilan Jurik

Actions

Related issues

Is duplicate of illumos gate - Bug #4989: removal of ntfsprogs and partedClosed2014-07-10

Actions

History

#1

Updated by Rich Lowe over 8 years ago

You're still going to have to provide a credible flag-day crossing mechanism. That's going to involve the userland gate producing packages anyone can install, without dances involving newer versions of pkg:/package/pkg, the OI -experimental repo, or the like.

#2

Updated by Milan Jurik over 8 years ago

I plan to provide IPS repo available on top of prestable OI build, available through rsync (file based) and http.

Maybe I can provide also SVR4 but I think only OI has support for SVR4.

Anyway, I will submit RTI to Illumos and Userland and putbacks have to be coordinated.

#3

Updated by Jim Klimov over 8 years ago

On one hand, (g)parted is actively used in the OI LiveCD/USB installer, but that can still be done with them in the userland. Greater question is on the other hand: whether format/fdisk support the large HDDs and GPT table (as container for Solaris partitions with slices for ZFS and possibly other Solaris-compatible FSes)?
That is, can an illumos-based system without parted work with large drives (other than giving the whole drive to ZFS as a pool component, which is what most people would probably do in reality).

I don't have a big drive to test, so an experiment with a yes/no answer would sufice ;)

Thanks,
//Jim Klimov

#4

Updated by Milan Jurik over 8 years ago

I do not know how far I would like to go. Probably as the first step just move to Userland as combination of upstream 1.8.8 version and Solaris specific patch. Then sync with upstream and how knows... Volunteers welcomed :-)

#5

Updated by Yuri Pankov about 6 years ago

  • Status changed from New to Closed

Done in #4989.

Also available in: Atom PDF